HDU-5363 Key Set 【快速幂取模+递推】

Key Set

Time Limit:1000MS Memory Limit:131072KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
soda has a set S with n integers {1, 2, \dots, n}. A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of S are key set.

Input
There are multiple test cases. The first line of input contains an integer T (1 \le T \le 10^5), indicating the number of test cases. For each test case:

The first line contains an integer n (1 \le n \le 10^9), the number of integers in the set.

Output
For each test case, output the number of key sets modulo 1000000007.

Sample Input
4
1
2
3
4

Sample Output
0
1
3
7


  1. 题意:给定一个集合{1,2,3……n},求此集合的非空子集中 key set的个数对1000000007的余数;key set:集合中所有的元素之和为偶数。
  2. 思路:递归思想:设集合{1 ,2,3……n}的key set个数为f(n),那么{1,2,,3……,n-1}的key set个数为f(n-1). 讨论: 1.n为偶数,f(n)=f(n-1)+f(n-1)+1; 2.n为奇数,f(n)=f(n-1)+2^(n-1)-1. 最后推导出公式f(n)=2^(n-1)-1; 在这里不再叙述,其实就是n这个元素加入到原来的·集合会产生多少·key set,没思路的话举例子也可以推出来(含n个元素的集合的幂集中的元素个数为2^n)
  3. 失误:刚开确实没思路,也不想举例子。
  4. 代码如下:

#include<cstdio>

__int64 quickpow(__int64 base ,__int64 m,__int64 mod)
{
    __int64 ans=1;

    while(m>0)
    {
        if(m&1)
        {
            ans=(ans*base)%mod;
            --m; 
        }

        base=(base*base)%mod;
        m/=2;
    }

    return ans;
}

int main()
{
    __int64 t,n,c;
    scanf("%I64d",&t);

    while(t--)
    {
        scanf("%I64d",&n);

        c=quickpow(2,n-1,1000000007)-1;

        printf("%I64d\n",c);
    }
    return 0;
 } 
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值