【HDU】-2647-Reward(反向拓扑)

Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7468    Accepted Submission(s): 2354


Problem Description
Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
 

Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
 

Output
For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
 

Sample Input
  
  
2 1 1 2 2 2 1 2 2 1
 

Sample Output
  
  
1777 -1
 

题解:代码中我觉得特别好的地方就是记录每一轮的增加量的方法。

反向拓扑,最先能满足所有人就给 888,以后他的每一个父节点都 +1。再次找到入度为0的点时 s (相对888多的钱)就变成了1。以此类推......

#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
#define CLR(a,b)  memset(a,b,sizeof(a))
int n,m,num,s;
long long ans;
int in[10010];
struct node
{
	int from,to;
}mapp[20010];
void init()
{
	s=0;						
	num=0;						//num和n相同就是可以满足所有条件的 
	ans=0;
	for(int i=1;i<=n;i++)
		in[i]=0;
}
void topo()
{	
	queue<int> q;
	while(!q.empty())
		q.pop();
	while(1)	
	{
		int flag=0;
		for(int i=1;i<=n;i++)
		{
			if(!in[i])
			{
				q.push(i);				//把所有入度为0的点都推进队列 
				num++;					
				ans+=s;					//开始s=0,因为第一次入度为0,不需要给他加钱,888可以满足 
				flag=1;					//有入度为0的点,flag=1 
				in[i]=-1;				//入度变为-1 
			}		
		}
		if(!flag)
			break;
		while(!q.empty())
		{
			int t=q.front();
			q.pop();
			for(int i=1;i<=m;i++)
			{
				if(mapp[i].from==t)
					in[mapp[i].to]--;
			}
		}
		s++;				//每一轮结束所有入度为0的点,s++,因为下一轮每个入度为0的点得到的至少比他多1 
	}
}
int main()
{
	while(~scanf("%d %d",&n,&m))
	{
		init();
		int a,b;
		for(int i=1;i<=m;i++)
		{
			scanf("%d %d",&a,&b);
			mapp[i].from=b;
			mapp[i].to=a;
			in[mapp[i].to]++;
		}
		topo();
		if(num!=n)			
			printf("-1\n");
		else
			printf("%lld\n",ans+n*888);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值