Bellovin
Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 996 Accepted Submission(s): 447
Problem Description
Peter has a sequence
a1,a2,...,an
and he define a function on the sequence --
F(a1,a2,...,an)=(f1,f2,...,fn)
, where
fi
is the length of the longest increasing subsequence ending with
ai
.
Peter would like to find another sequence b1,b2,...,bn in such a manner that F(a1,a2,...,an) equals to F(b1,b2,...,bn) . Among all the possible sequences consisting of only positive integers, Peter wants the lexicographically smallest one.
The sequence a1,a2,...,an is lexicographically smaller than sequence b1,b2,...,bn , if there is such number i from 1 to n , that ak=bk for 1≤k<i and ai<bi .
Peter would like to find another sequence b1,b2,...,bn in such a manner that F(a1,a2,...,an) equals to F(b1,b2,...,bn) . Among all the possible sequences consisting of only positive integers, Peter wants the lexicographically smallest one.
The sequence a1,a2,...,an is lexicographically smaller than sequence b1,b2,...,bn , if there is such number i from 1 to n , that ak=bk for 1≤k<i and ai<bi .
Input
There are multiple test cases. The first line of input contains an integer
T
, indicating the number of test cases. For each test case:
The first contains an integer n (1≤n≤100000) -- the length of the sequence. The second line contains n integers a1,a2,...,an (1≤ai≤109) .
The first contains an integer n (1≤n≤100000) -- the length of the sequence. The second line contains n integers a1,a2,...,an (1≤ai≤109) .
Output
For each test case, output
n
integers
b1,b2,...,bn
(1≤bi≤109)
denoting the lexicographically smallest sequence.
Sample Input
3 1 10 5 5 4 3 2 1 3 1 3 5
Sample Output
1 1 1 1 1 1 1 2 3
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
#define CLR(a,b) memset(a,b,sizeof(a))
int a[100010];
int dp[100010];
int g[100010];
int main()
{
int u;
scanf("%d",&u);
while(u--)
{
CLR(a,0);
int n,i;
scanf("%d",&n);
for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);
g[i]=INF;
dp[i]=0; //初始化 dp[i]=0
}
int ans=0;
for(i=1;i<=n;i++)
{
int k=lower_bound(g+1,g+1+n,a[i])-g;
dp[i]=max(k,dp[i]); //变化主要在这,理解。
g[k]=min(g[k],a[i]); //g[k]第k位现在的值,要求一直可以小就小
}
for(i=1;i<n;i++)
printf("%d ",dp[i]);
printf("%d\n",dp[n]);
}
return 0;
}