【HDU】-5748-Bellovin(LIS,变化)

Bellovin

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 996    Accepted Submission(s): 447


Problem Description
Peter has a sequence  a1,a2,...,an  and he define a function on the sequence --  F(a1,a2,...,an)=(f1,f2,...,fn) , where  fi  is the length of the longest increasing subsequence ending with  ai .

Peter would like to find another sequence  b1,b2,...,bn  in such a manner that  F(a1,a2,...,an)  equals to  F(b1,b2,...,bn) . Among all the possible sequences consisting of only positive integers, Peter wants the lexicographically smallest one.

The sequence  a1,a2,...,an  is lexicographically smaller than sequence  b1,b2,...,bn , if there is such number  i  from  1  to  n , that  ak=bk  for  1k<i  and  ai<bi .
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first contains an integer  n   (1n100000)  -- the length of the sequence. The second line contains  n  integers  a1,a2,...,an   (1ai109) .
 

Output
For each test case, output  n  integers  b1,b2,...,bn   (1bi109)  denoting the lexicographically smallest sequence.
 

Sample Input
  
  
3 1 10 5 5 4 3 2 1 3 1 3 5
 

Sample Output
  
  
1 1 1 1 1 1 1 2 3
 
题解:求最长上升子序列的变化题目。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
#define CLR(a,b)  memset(a,b,sizeof(a))
int a[100010];
int dp[100010];
int g[100010];
int main()
{
	int u;
	scanf("%d",&u);
	while(u--)
	{
		CLR(a,0);
		int n,i;
		scanf("%d",&n);
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			g[i]=INF;
			dp[i]=0;					//初始化 dp[i]=0 
		}
		int ans=0;
		for(i=1;i<=n;i++)
		{
			int k=lower_bound(g+1,g+1+n,a[i])-g;
			dp[i]=max(k,dp[i]);					//变化主要在这,理解。 
			g[k]=min(g[k],a[i]);				//g[k]第k位现在的值,要求一直可以小就小 
		}
		for(i=1;i<n;i++)
			printf("%d ",dp[i]);
		printf("%d\n",dp[n]);
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值