【HDU】-4324-Triangle LOVE(拓扑,环)

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 4666    Accepted Submission(s): 1837


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 

Sample Input
  
  
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

Sample Output
  
  
Case #1: Yes Case #2: No

题意:判断n个人中是否存在三角恋,即a->b,b->c,c->a;

题解:此题可以一遍拓扑排序判环求解 即只需要找到一个环,就必定存在三元环 

证明如下:

假设存在一个n元环,
因为a->b有边,b->a必定没边,反之也成
所以只需证明n大于3时一定有三元环即可,显然成立。

AC代码:

#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
#define CLR(a,b) memset(a,b,sizeof(a))
char a[2010][2010];			//放里面就崩了				
int main()
{
	int u,ca=1;
	scanf("%d",&u);
	while(u--)
	{	
		int n;
		int in[2010];	
		bool flag=false;
		CLR(in,0);
		CLR(a,0);
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%s",a[i]);
			for(int j=0;j<n;j++)
			{
				if(a[i][j]=='1')
				{
					in[j]++;		//a喜欢 b,b入度++ 
				}	
			}
		}
		int num=0;
		while(1)
		{
			int j;
			for(j=0;j<n;j++)
				if(in[j]==0)
					break;		//找到入度为 0 的点退出 
			if(j==n)
			{
				flag=true;
				break;			//所有的点入度都大于 0 ,就是存在环,存在三角恋 
			}
			else
			{			
				for(int i=0;i<n;i++)
				{
					if(a[j][i]=='1')		//注意这里,不要想当然,结合具体的题,具体的图来写				
						in[i]--;			//a[j][i]=='1',就是有关系,in[i]-- 
				}
				in[j]=-1;
				num++;
			}
			if(num==n)
				break;
		}
		if(flag)
			printf("Case #%d: Yes\n",ca++);
		else
			printf("Case #%d: No\n",ca++);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值