【P-oj】-Fibonacci(矩阵)

Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14466 Accepted: 10216

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:



题解:和第一道矩阵的题一样,只不过这里还有 F0=0而已;

#include <cstdio>
#include <stack>
#include <queue>
#include <cmath>
#include <vector>
#include <cstring>
#include <algorithm>
using namespace std;
#define CLR(a,b) memset(a,b,sizeof(a))
#define INF 0x3f3f3f3f
#define LL long long
const LL MOD = 1e4;
struct Matrix
{
	int h,w;
	int m[5][5];
};
Matrix Matrix_multiply(Matrix a,Matrix b)
{
	Matrix c;
	c.h=a.h;
	c.w=b.w;
	CLR(c.m,0);
	for(int i=1;i<=a.h;i++)
	{
		for(int j=1;j<=a.w;j++)
		{
			if(a.m[i][j]==0)
				continue;
			for(int k=1;k<=b.w;k++)
				c.m[i][k]=(c.m[i][k]+a.m[i][j]*b.m[j][k]%MOD)%MOD;
		}
	}
	return c;
}
Matrix Quick(Matrix a,int n)
{
	Matrix ans;
	ans.h=ans.w=a.h;
	CLR(ans.m,0);
	for(int i=1;i<=a.h;i++)	
		ans.m[i][i]=1;
	while(n)
	{
		if(n&1)
			ans=Matrix_multiply(ans,a);
		n>>=1;
		a=Matrix_multiply(a,a);
	}
	return ans;
}
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		if(n==0)
			printf("0\n");
		else if(n==-1)	
			break;
		else
		{
				Matrix pr,now,anss;
			pr.h=pr.w=2;
			CLR(pr.m,0);
			pr.m[1][1]=pr.m[1][2]=pr.m[2][1]=1,pr.m[2][2]=0;
			now.h=1,now.w=2;
			now.m[1][1]=1,now.m[1][2]=1;
			CLR(anss.m,0);
			anss=Matrix_multiply(now,Quick(pr,n-1));
			printf("%d\n",anss.m[1][2]);
		}
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值