1002: A+B (III)

Description

Your task is to Calculate a + b.

Input

There are multiple test cases. Each test case contains only one line. Each line consists of a pair of integers a and b ( 1 <= ab <=1016 ) , separated by a space. Input is followed by a single line with a = 0, b = 0, which should not be processed.

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input

1 5
10 20
10000000000000000 10000000000000000
0 0

Sample Output

6
30
20000000000000000

题目大意

高精度加法

解题思路

模拟竖式

AC Code

#include<iostream>
#include<string>
using namespace std;
const int MAXN=10000+10;
string add(string &a, string &b){
	string ans;
	int la=a.size(), lb=b.size();
	int na[MAXN], nb[MAXN];
	for(int i=la-1; i>=0; --i)
		na[la-i-1]=a[i]-'0';
	for(int i=lb-1; i>=0; --i)
		nb[lb-i-1]=b[i]-'0';
	int lmax=la>lb?la:lb;
	for(int i=0; i<lmax; ++i){
		na[i]+=nb[i];
		na[i+1]+=na[i]/10;
		na[i]%=10;
	}
	if(na[lmax]) lmax++;
	for(int i=lmax-1; i>=0; --i)
		ans+=na[i]+'0';
	return ans;
}
int main(){
	string a, b;
	while(cin>>a>>b){
		if(a=="0" && b=="0") break;
		cout<<add(a,b)<<endl;
	}
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值