2012 ACM/ICPC Asia Regional Chengdu Online(hdu4292)

Food

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 556    Accepted Submission(s): 247


Problem Description
  You, a part-time dining service worker in your college’s dining hall, are now confused with a new problem: serve as many people as possible.
  The issue comes up as people in your college are more and more difficult to serve with meal: They eat only some certain kinds of food and drink, and with requirement unsatisfied, go away directly.
  You have prepared F (1 <= F <= 200) kinds of food and D (1 <= D <= 200) kinds of drink. Each kind of food or drink has certain amount, that is, how many people could this food or drink serve. Besides, You know there’re N (1 <= N <= 200) people and you too can tell people’s personal preference for food and drink.
  Back to your goal: to serve as many people as possible. So you must decide a plan where some people are served while requirements of the rest of them are unmet. You should notice that, when one’s requirement is unmet, he/she would just go away, refusing any service.
 

Input
  There are several test cases.
  For each test case, the first line contains three numbers: N,F,D, denoting the number of people, food, and drink.
  The second line contains F integers, the ith number of which denotes amount of representative food.
  The third line contains D integers, the ith number of which denotes amount of representative drink.
  Following is N line, each consisting of a string of length F. e jth character in the ith one of these lines denotes whether people i would accept food j. “Y” for yes and “N” for no.
  Following is N line, each consisting of a string of length D. e jth character in the ith one of these lines denotes whether people i would accept drink j. “Y” for yes and “N” for no.
  Please process until EOF (End Of File).
 

Output
  For each test case, please print a single line with one integer, the maximum number of people to be satisfied.
 

Sample Input
  
  
4 3 3 1 1 1 1 1 1 YYN NYY YNY YNY YNY YYN YYN NNY
 

Sample Output
  
  
3
 

Source
 

Recommend
liuyiding

最大流题,比较基础,但是比赛的时候状态太差了,用Dinic没写出来,唉!

设F个食物节点,和D个饮料节点,把N个人节点拆成两个点,从源点连到食物节点,以食物的容量为权值,再从食物连到人的前N个点,再从人的后N个节点连到饮料的D个节点,最后从饮料的D个节点连到汇点。

Code:

#include<cstdio>
#include<iostream>
using namespace std;
const int oo=1e9;
const int mm=1111111;
const int mn=999;
int node,src,dest,edge;
int ver[mm],flow[mm],next[mm];
int head[mn],work[mn],dis[mn],q[mn];
int N,F,D;
char pp[202];
int f,d;
void prepare(int _node,int _src,int _dest)
{
    node=_node,src=_src,dest=_dest;
    for(int i=0; i<node; ++i)head[i]=-1;
    edge=0;
}

void addedge(int u,int v,int c)
{
    ver[edge]=v,flow[edge]=c,next[edge]=head[u],head[u]=edge++;
    ver[edge]=u,flow[edge]=0,next[edge]=head[v],head[v]=edge++;
}

bool Dinic_bfs()
{
    int i,u,v,l,r=0;
    for(i=0; i<node; ++i)dis[i]=-1;
    dis[q[r++]=src]=0;
    for(l=0; l<r; ++l)
        for(i=head[u=q[l]]; i>=0; i=next[i])
            if(flow[i]&&dis[v=ver[i]]<0)
            {
                dis[q[r++]=v]=dis[u]+1;
                if(v==dest)return 1;
            }
    return 0;
}
int Dinic_dfs(int u,int exp)
{
    if(u==dest)return exp;
    for(int &i=work[u],v,tmp; i>=0; i=next[i])
        if(flow[i]&&dis[v=ver[i]]==dis[u]+1&&(tmp=Dinic_dfs(v,min(exp,flow[i])))>0)
        {
            flow[i]-=tmp;
            flow[i^1]+=tmp;
            return tmp;
        }
    return 0;
}
int Dinic_flow()
{
    int i,ret=0,delta;
    while(Dinic_bfs())
    {
        for(i=0; i<node; ++i)work[i]=head[i];
        while(delta=Dinic_dfs(src,oo))ret+=delta;
    }
    return ret;
}
int main()
{

    while(cin>>N>>F>>D)
    {
        int sum=F+2*N+D+2;
        prepare(sum,0,sum-1);//初始化
        for(int i=1; i<=F; i++)   //连接源点到F个食物点,权值为f
        {
            scanf("%d",&f);
            addedge(src,i,f);
        }

        for(int i=1; i<=D; i++)//连接汇点到D个饮料点,权值为d
        {
            scanf("%d",&d);
            addedge(F+2*N+i,dest,d);
        }

        for(int i=1; i<=N; i++)      //人与人前后点之间建立一条权值为1 的边
            addedge(F+i,F+N+i,1);

        for(int i=1; i<=N; i++)
        {
            scanf("%s",pp);
            for(int j=0; j<F; j++)   //如果满足Y,则在食物和人前点建立一条权值为1的边
                if(pp[j]=='Y')
                    addedge(j+1,F+i,1);
        }

        for(int i=1; i<=N; i++)
        {
            scanf("%s",pp);
            for(int j=0; j<D; j++)      //如果满足Y,则在饮料和人后点建立一条权值为1的边
                if(pp[j]=='Y')
                    addedge(F+N+i,F+2*N+j+1,1);
        }
        printf("%d\n",Dinic_flow());       
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值