POJ2299

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 28822 Accepted: 10346

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source

树状数组,因为a[i]可能会到999999999,所以直接开到这么大的数组是不行的,要进行处理。
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;
const int maxn=500005;
int tree[maxn];
int N;
int b[maxn];
struct node
{
    int num,id;
} a[maxn];
inline int Lowbit(int x)
{
    return x&(-x);
}
void Update(int x)
{
    int i;
    for(i=x; i<=N; i+=Lowbit(i))
        tree[i]++;
}
long long Getsum(int x)
{
    long long s=0;
    int i;
    for(i=x; i>0; i-=Lowbit(i))
        s+=tree[i];
    return s;
}
bool cmp(node a,node b)
{
    return a.num<b.num;
}
int main()
{
    while(scanf("%d",&N)!=-1&&N)
    {
        for(int i=0; i<=N; i++)
            tree[i]=0;
        for(int i=1; i<=N; i++)
        {
            scanf("%d",&b[i]);
            a[i].num=b[i],a[i].id=i;
        }
        sort(a+1,a+N+1,cmp);
        for(int i=1; i<=N; i++)
            b[a[i].id]=i;
        long long ans=0;
        for(int i=1; i<=N; i++)
        {

            long long temp=Getsum(N)-Getsum(b[i]);
            ans+=temp;
            Update(b[i]);
        }
        printf("%lld\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值