POJ 1971 Parallelogram Counting (Hash)

Parallelogram Counting
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 5625 Accepted: 1890

Description

There are n distinct points in the plane, given by their integer coordinates. Find the number of parallelograms whose vertices lie on these points. In other words, find the number of 4-element subsets of these points that can be written as {A, B, C, D} such that AB || CD, and BC || AD. No four points are in a straight line.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases. It is followed by the input data for each test case. 
The first line of each test case contains an integer n (1 <= n <= 1000). Each of the next n lines, contains 2 space-separated integers x and y (the coordinates of a point) with magnitude (absolute value) of no more than 1000000000. 

Output

Output should contain t lines. 
Line i contains an integer showing the number of the parallelograms as described above for test case i. 

Sample Input

2
6
0 0
2 0
4 0
1 1
3 1
5 1
7
-2 -1
8 9
5 7
1 1
4 8
2 0
9 8

Sample Output

5
6

Source

枚举所有对角线,对中点进行Hash即可。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define N 1005
#define mod 1000007
int x[N],y[N];
struct point
{
    int x,y,cnt;
};
struct hashtable
{
    int h[mod],p[mod],size;
    point s[mod];
    int hash(int x,int y)
    {
        return ((x*131+y+mod)&0x7FFFFFFF)%mod;
    }
    void insert(int x,int y)
    {
        int i,id=hash(x,y);
        for(i=h[id]; ~i; i=p[i])
            if(s[i].x==x&&s[i].y==y)
            {
                s[i].cnt++;
                return;
            }
        s[size].cnt=1;
        s[size].x=x,s[size].y=y;
        p[size]=h[id],h[id]=size++;
    }
    int find(int x,int y)
    {
        int i,id=hash(x,y);
        for(i=h[id]; ~i; i=p[i])
            if(s[i].x==x&&s[i].y==y) return i;
        return 0;
    }
    void clear()
    {
        size=1;
        memset(h,-1,sizeof(h));
    }
} ht;
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        ht.clear();
        scanf("%d",&n);
        for(int i=0; i<n; ++i)
            scanf("%d%d",x+i,y+i);
        for(int i=0; i<n; ++i)
            for(int j=i+1; j<n; ++j)
                ht.insert(x[i]+x[j],y[i]+y[j]);
        int ans=0;
        for(int i=0; i<mod; ++i)
            for(int j=ht.h[i]; ~j; j=ht.p[j])
            {
                int tmp=ht.s[j].cnt;
                ans+=((tmp-1)*tmp)/2;
            }
        printf("%d\n",ans);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值