HDU-1253 胜利大逃亡

HDU-1253 胜利大逃亡

Time Limit: 4000/2000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.
魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.
这里写图片描述

Input

输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块……),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

Output

对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

Sample Input
1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0
Sample Output
11


题目网址:http://acm.hdu.edu.cn/showproblem.php?pid=1253

分析

思路:广搜题,只不过是从二维编程三维,没有什么坑。如果想不出来的话可以参考一下二维的是如何搜索的。

代码
#include <iostream>
#include <stdio.h>
#include <queue>
#include <string.h>
using namespace std;
int dt[55][55][55],xyz[6][3]={1,0,0,-1,0,0,0,-1,0,0,1,0,0,0,1,0,0,-1},temp[55][55][55],x,y,z,te;
struct cmp
{
    int i,j,z,pre;
    friend bool operator < (cmp a,cmp b)
    {
        return a.pre>b.pre;
    }
};
priority_queue<cmp>it;
int BFS()
{
    memset(temp,0,sizeof(temp));
    cmp e,o;
    e.i=0;
    e.j=0;
    e.z=0;
    e.pre=0;
    it.push(e);
    temp[e.i][e.j][e.z]=1;
    if (x+y+z-3>te)
        return -1;
    while (!it.empty())
    {
        e=it.top();
        it.pop();
        for (int t=0;t<6;t++)
        {
            o=e;
            o.i+=xyz[t][0];
            o.j+=xyz[t][1];
            o.z+=xyz[t][2];
            if (dt[o.i][o.j][o.z]==1||temp[o.i][o.j][o.z]==1||o.i>=x||o.j>=y||o.z>=z||o.i<0||o.j<0||o.z<0)
                continue;
            o.pre++;
            if (o.i==x-1&&o.j==y-1&&o.z==z-1)
            {
                return o.pre;
            }
            if (x+y+z+o.pre-o.i-o.j-o.z-3>te)
                continue;
            temp[o.i][o.j][o.z]=1;
            it.push(o);
        }
    }
    return -1;
}
int main()
{
    int n;
    scanf("%d",&n);
    for (int h=0;h<n;h++)
    {
        while (!it.empty())
        {
            it.pop();
        }
        scanf("%d %d %d %d",&x,&y,&z,&te);
        for (int j=0;j<x;j++)
            for (int k=0;k<y;k++)
                for (int l=0;l<z;l++)
                    scanf("%d",&dt[j][k][l]);
        int num=BFS();
        printf("%d\n",num);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值