HDU-1021 Fibonacci Again

HDU-1021 Fibonacci Again

Time Limit : 2000/1000ms (Java/Other)
Memory Limit : 65536/32768K (Java/Other)

Problem Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word “yes” if 3 divide evenly into F(n). Print the word “no” if not.

Sample Input
0
1
2
3
4
5
Sample Output
no
no
yes
no
no
no


题目网址:http://acm.hdu.edu.cn/showproblem.php?pid=1021

分析

题意:估计不用我说,也能看懂题意。

思路:水题一个,不过在数据处理方面需要花点小心思,因为这一题的数据有点大,无论是double还是long long double都是会超限的,这就需要你每次计算的时候都要对3进行取余。因为如果一个数能被3整除,那这个数你加不加都不影响结果是否能被3整出,就比如说3+5的结果能否被3整出是取决于5能否被3整除。

代码
#include <iostream>
#include <stdio.h>
using namespace std;
long long num[1000001];
void Fnum()
{
    num[0]=7%3;
    num[1]=11%3;
    for (int i=2;i<1000001;i++)
        num[i]=(num[i-1]+num[i-2])%3;
}
int main()
{
    Fnum();
    int n;
    while (~scanf("%d",&n))
    {
        if (num[n]%3==0)
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值