HDU1004---Let the Balloon Rise

 小萌新第一次学STL,哇塞,那真是带(meng)劲(bi),完全看不懂啊有木有。没办法,只能从例题入手试着去摸索一下了。

 

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

 

 

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

 

 

Sample Input

5

green

red

blue

red

red

3

pink

orange

pink

0

 

Sample Output

red
pink

 

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1004

先上代码

#include<iostream>
#include<string>
#include<map>
using namespace std;
int main()
{
    int n;
    string s;
    map<string,int>m;
    int max1;
    string colormax;//定义最大次数对应的颜色
    while(cin>>n&&n>0)
    {
        if(n==0) break;
        m.clear();//记得清空
        for(int i=0;i < n; i++)
        {
            cin>>s;
            m[s]++;
        }
        max1=0;//定义最大的出现次数
        for(map<string,int>::iterator it=m.begin();it!=m.end();it++)//遍历..
        {
            if(it->second>max1)
            {
                max1=it->second;//max1=(*it).second;
                colormax=it->first;//colormax=(*it).first;
            }
        }
        cout<<colormax<<endl;
    }
    return 0;
}

1.从题目可以知道,每种颜色(string)对应一个出现的次数(int),所以用map;

2.map的功能:自动建立Key - value的对应。key 和 value可以是任意你需要的类型。 根据key值快速查找记录,查找的复杂度基本是Log(N),如果有1000个记录,最多查找10次,1,000,000个记录,最多查找20次;

3.map使用:map对象是模板类,需要关键字和存储对象两个模板参数:std:map<int, string> personnel;这样就定义了一个用int作为索引,并拥有相关联的指向string的指针;(该题用<string,int>)

3.遍历的时候,begin()和end()两个成员,分别代表map对象中第一个条目和最后一个条目,这两个数据的类型是iterator;

4。通过map对象的方法获取的iterator数据类型是一个std::pair对象,包括两个数据 iterator->first 和 iterator->second 分别代表关键字和存储的数据

小萌新从这个题,暂时就了解这么多基础的吧,如有说错的,还请大佬批评,O(∩_∩)O谢谢。

ps:更多内容,请看https://www.cnblogs.com/hailexuexi/archive/2012/04/10/2440209.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值