POJ1611(并查集)

The Suspects---题目地址

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

题目大意:一学校检查SARS病毒,学校有n人,分成了m组,一组中只要有一人带有病毒,该组都会被感染。之后m行,每一行的第一个数k表示该组有多少人,输入k个编号。学生编号从0到n-1,初始怀疑0号携带病毒,问该学校按传染关系有多少人携带病毒。

AC代码及注释:

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
int pre[33000];//pre[i]表示i的父节点是pre[i];
int nums[33000];
int find(int x)//找最终父节点,即没人在他上边,父节点为本身(pre[i]=i)
{
    if(x!=pre[x]) pre[x]=find(pre[x]);
    return pre[x];
}
void join(int x,int y)//合并两个集合
{
    int dx=find(x);
    int dy=find(y);
    if(dx!=dy) pre[dx]=dy;//如果x和y的最终父节点不相等
}
//find和jion函数就是并查集的模板代码
int main()
{
    int n,m;
    while(cin>>n>>m&&(m||n))
    {
        int a,b,c=0;
        memset(nums,0,sizeof nums);
        for(int i=0;i<n;i++) pre[i]=i;//初始化pre数组
        while(m--)
        {
            cin>>a;
            if(a>=1)
            {
                cin>>nums[0];
                for(int i=1;i<a;i++)
                {
                    cin>>nums[i];
                    join(nums[0],nums[i]);//该组的每个人都与该组第一个数有关系
                }
            }
        }
        int ans=0;
        for(int i=0;i<n;i++)
        {
            if(find(i)==pre[0]) ans++;//如果i的最终父节点等于0的父节点,即如果i和0有关系
        }
        cout<<ans<<endl;
    }
    return 0;
}

编程小白,还请多多指教。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值