1poj1611(并查集)

http://poj.org/problem?id=1611

The Suspects
Time Limit: 1000MSMemory Limit: 20000K
Total Submissions: 15428Accepted: 7364

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source

 

有很多组学生,在同一个组的学生经常会接触,也会有新的同学的加入。但是SARS是很容易传染的,只要在改组有一位同学感染SARS,那么该组的所有同学都被认为得了SARS。现在的任务是计算出有多少位学生感染SARS了。假定编号为0的同学是得了SARS的。

解题思路---->显然并查集了。采用num[]存储该集合中元素个数,并在集合合并时更新num[]即可。然后找出0所在的集合的根节点x,因此,num[x]就是answer了。

//并查集主要操作1初始化2查找3合并

#include<stdio.h>
int father[30001],num[30001];//num存储节点所在集合元素的个数father[]存储节点的父节点
void Make_Set(int x)//初始化集合(把每个点所在集合初始化为其自身)
{
 father[x]=x;
 num[x]=1;//这边注意 初始化每个集合都只有一人
}
int Find_Set(int x)//2查找x元素所在的集合,回溯时压缩路径 返回x所在集合的根节点
{
 if(x!=father[x])
 {
  father[x]=Find_Set(father[x]);//路劲压缩
 }
 return father[x];
}
void Union_Set(int a,int b)/// 3合并a,b所在的集合
{
 if(a==b)// 如果两个元素在同一个集合则不需要合并
  return;
 if(num[a]<=num[b])//将小集合合并到大集合中,更新集合个数
 {
  father[a]=b;
  num[b]+=num[a];
 }
 else
 {
  father[b]=a;
  num[a]+=num[b];
 }
}
int main()
{
 int n,m;
 int t=1;
 while(scanf("%d %d",&n,&m)!=EOF)
 {

  if(n==0&&m==0)
   break;
  int i;
  for(i=0;i<n;i++)//将每个节点作为一个集合
  {
   Make_Set(i);
  }
  int a,b;
  int k,j,x,y;
  for(i=0;i<m;i++)
  {
   scanf("%d",&k);
   scanf("%d",&x);
   for(j=1;j<k;j++)
   {
    scanf("%d",&y);
    a=Find_Set(x);
    b=Find_Set(y);
    Union_Set(a,b);
   }
  }
  printf("%d\n",num[Find_Set(father[0])]);//找出0所在集合的祖先节点
 }
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值