算法学习【17】—— 1193. Up the Stairs

题目来源: http://soj.me/1193

1193. Up the Stairs

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

John is moving to the penthouse of a tall sky-scraper. He packed all his stuff in boxes and drove them to the entrance of the building on the ground floor. Unfortunately the elevator is out of order, so the boxes have to be moved up the stairs. 
Luckily John has a lot of friends that want to help carrying his boxes up. They all walk the stairway at the same speed of 1 floor per minute, regardless of whether they carry a box or not. The stairway however is so narrow that two persons can't pass each other on it. Therefore they deciced to do the following: someone with a box in his hands is always moving up and someone empty-handed is always moving down. When two persons meet each other somewhere on the stairway, the lower one (with a box) hands it over to the higher one (without a box). (And then the lower one walks down again and the higher one walks up.) The box exchange is instantaneous. When someone is back on the ground floor, he picks up a box and starts walking up. When someone is at the penthouse, he drops the box and walks down again. 

After a while the persons are scattered across the stairway, some of them with boxes in their hands and some without. There are still a number of boxes on the ground floor and John is wondering how much more time it will take before all the boxes are up. Help him to find out!

Input

One line with a positive number: the number of test cases. Then for each test case: 

  • One line with three numbers N, F, B with 1 ≤ N,F ≤ 1000 and 1 ≤ B ≤ 1000000: the number of persons, the number of floors (0=ground floor, F=penthouse) and the number of boxes that are still on the ground floor.
  • N lines with two numbers fi and bi with 0 ≤ fi ≤ F and bi = 0 or bi = 1: the floors where the persons are initially and whether or not they have a box in their hands (1=box, 0=no box).

Output

One line with the amount of time (in minutes) it will take to get all the remaining boxes to the penthouse.

Sample Input

2
3 10 5
0 0
0 0
0 0
2 5 1
2 1
3 0

Sample Output

30
8

思路:开始审题,判断为模拟类型。不过在处理模型方面出了点问题,没有考虑到两人相交类似穿透,即是可是忽略所谓的交换过程。然后也没有考虑到周期性,即是可以先定义 每个朋友的初始完成将ground floor的盒子搬上penthouse任务的时间。然后接下来的就是周期性的2*floorNum搬运时间了。最初的搬运过程,是取耗时最长的朋友所花费的时间。然后就没有然后了。应该简化模型。

代码:

/*
Link: http://soj.me/1193
Author: BetaBin
Date: 2012/07/26
*/
#include <stdio.h>
#include <algorithm>

int floorNum;
int friendNum;
int boxleftNum;

int originalUpTime[1005];

int testNum;
int timeCost;
int lastOne;
int i,j,k;

int main()
{
    scanf("%d", &testNum);
    while(testNum--)
    {
        scanf("%d %d %d", &friendNum, &floorNum, &boxleftNum);
        for(i = 0; i < friendNum; i++)
        {
            scanf("%d %d", &j, &k);
            if(k)
            {
                originalUpTime[i] = 3 * floorNum - j;
            }
            else
            {
                originalUpTime[i] = floorNum + j;
            }
        }
        std::sort(originalUpTime, originalUpTime + friendNum);
        lastOne = boxleftNum % friendNum;
        if(lastOne)
        {
            timeCost = (boxleftNum / friendNum) * 2 * floorNum + originalUpTime[lastOne - 1];
        }
        else
        {
            timeCost = (boxleftNum / friendNum - 1) * 2 * floorNum + originalUpTime[friendNum - 1];
        }
        printf("%d\n", timeCost);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值