sicily 1193. Up the Stairs

1193. Up the Stairs

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

John is moving to the penthouse of a tall sky-scraper. He packed all his stuff in boxes and drove them to the entrance of the building on the ground floor. Unfortunately the elevator is out of order, so the boxes have to be moved up the stairs.
Luckily John has a lot of friends that want to help carrying his boxes up. They all walk the stairway at the same speed of 1 floor per minute, regardless of whether they carry a box or not. The stairway however is so narrow that two persons can't pass each other on it. Therefore they deciced to do the following: someone with a box in his hands is always moving up and someone empty-handed is always moving down. When two persons meet each other somewhere on the stairway, the lower one (with a box) hands it over to the higher one (without a box). (And then the lower one walks down again and the higher one walks up.) The box exchange is instantaneous. When someone is back on the ground floor, he picks up a box and starts walking up. When someone is at the penthouse, he drops the box and walks down again.

After a while the persons are scattered across the stairway, some of them with boxes in their hands and some without. There are still a number of boxes on the ground floor and John is wondering how much more time it will take before all the boxes are up. Help him to find out!

Input

One line with a positive number: the number of test cases. Then for each test case:

  • One line with three numbers N, F, B with 1 ≤ N,F ≤ 1000 and 1 ≤ B ≤ 1000000: the number of persons, the number of floors (0=ground floor, F=penthouse) and the number of boxes that are still on the ground floor.
  • N lines with two numbers fi and bi with 0 ≤ fi ≤ F and bi = 0 or bi = 1: the floors where the persons are initially and whether or not they have a box in their hands (1=box, 0=no box).

Output

One line with the amount of time (in minutes) it will take to get all the remaining boxes to the penthouse.

Sample Input

2
3 10 5
0 0
0 0
0 0
2 5 1
2 1
3 0

Sample Output

30
8

题目分析

搬箱子上楼梯,题目大意是

楼梯上站着n个人,楼下有m件货品,

拿着东西的人只能上楼,没拿东西的人只能下楼,

如果相遇了两人则传递物品,交换身份

问最终耗时

初看题目,直接模拟的话要考虑判断很多情况,互换身份很麻烦

思考后发现扩宽楼道,即让每个人自己走自己的路,其实总的用时是一样的

直接模拟,超时了

别人的思路是直接确定哪个人会拿最后一个,然后确定用时

想想确实有道理

根据每个人现在的位置和状态,不难确定他会去拿第几个箱子

(有箱子的先向上再向下,没箱子的直接向下)

之后每轮拿箱子都是这个次序

交付第一轮箱子只要上一次楼梯即可

之后的每轮交付都需要先下再上

只要确定了是哪个人在第几轮交付即可


#include <cstdio>
#include <iostream>
#include <algorithm>

struct Person {
  int pos;
  int withgoods;
  int steps;
};

bool com(Person a, Person b) {
  return a.steps < b.steps;
}

int main()
{
  int test;
  scanf("%d", &test);
  while (test--) {
    int people, floors, goods;
    scanf("%d%d%d", &people, &floors, &goods);
    Person per[people];
    for (int i = 0; i < people; ++i) {
      scanf("%d%d", &per[i].pos, &per[i].withgoods);
      if (per[i].withgoods) {
        per[i].steps = floors - per[i].pos + floors;
      } else {
        per[i].steps = per[i].pos;
      }
    }
    std::sort(per, per+people, com);
    int ans;
    int count = goods / people;
    int index = (goods-1) % people;
    if (index == people-1) {
      ans = per[index].steps + (count*2-1) * floors;
    } else {
      ans = per[index].steps + (count*2+1) * floors;
    }
    printf("%d\n", ans);
  }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值