BZOJ4580: [Usaco2016 Open]248 dp

12 篇文章 0 订阅

Description
Bessie likes downloading games to play on her cell phone, even though she does find the small touch
screen rather cumbersome to use with her large hooves.She is particularly intrigued by the current g
ame she is playing. The game starts with a sequence of NN positive integers (2≤N≤248), each in the
range 1…40. In one move, Bessie can take two adjacent numbers with equal values and replace them a
single number of value one greater (e.g., she might replace two adjacent 7s with an 8). The goal is
to maximize the value of the largest number present in the sequence at the end of the game. Please
help Bessie score as highly as possible!

Input
The first line of input contains N, and the next N lines give the sequence of N numbers at the start
of the game.

Output

Please output the largest integer Bessie can generate.

Sample Input
4

1

1

1

2
Sample Output
3

//In this example shown here, Bessie first merges the second and third 1s to obtain the sequence 1 2 2

, and then she merges the 2s into a 3. Note that it is not optimal to join the first two 1s.
**题解:
维护一个二位dp,表示一个值往后找最多能找到的地方,再转移一下就行**

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int MAXN=1<<18|1;
int dp[MAXN][57],a[MAXN];
int main(int argc, char *argv[])
{
    int n,i,j,ans=0;
    scanf("%d",&n);
    for(i=1;i<=n;i++) {
        scanf("%d",&a[i]);
        dp[i][a[i]]=i;
        j=i-1;
        while(dp[j][a[i]]) {
            j=dp[j][a[i]]-1; 
            a[i]++; 
            dp[i][a[i]]=j+1; 
        }
        if(ans<a[i]) ans=a[i];
    }
    printf("%d\n",ans);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值