bzoj 4580: [Usaco2016 Open]248 (dp)

4580: [Usaco2016 Open]248

Time Limit: 10 Sec   Memory Limit: 128 MB
Submit: 99   Solved: 78
[ Submit][ Status][ Discuss]

Description

Bessie likes downloading games to play on her cell phone, even though she does find the small touch 
screen rather cumbersome to use with her large hooves.She is particularly intrigued by the current g
ame she is playing. The game starts with a sequence of NN positive integers (2≤N≤248), each in the
 range 1…40. In one move, Bessie can take two adjacent numbers with equal values and replace them a
 single number of value one greater (e.g., she might replace two adjacent 7s with an 8). The goal is
 to maximize the value of the largest number present in the sequence at the end of the game. Please 
help Bessie score as highly as possible!

Input

The first line of input contains N, and the next N lines give the sequence of N numbers at the start
 of the game.

Output

Please output the largest integer Bessie can generate.

Sample Input

4
1
1
1
2

Sample Output

3
//In this example shown here, Bessie first merges the second and third 1s to obtain the sequence 1 2 2
, and then she merges the 2s into a 3. Note that it is not optimal to join the first two 1s.

HINT

Source

[ Submit][ Status][ Discuss]


题解:dp

f[i][j][k]表示区间[i,j]变成k是否可行,然后每次得到一个新的数就更新答案。理论复杂度不是很科学,但是有很多的不合法状态可以舍去。

其实可以变成二维的转移,f[i][j]表示区间[i,j]合并成一个数的最大值。那么这样会不会有一个值不这么合并的时候更优呢?因为是枚举长度和区间,所以那样一定是某种状态下的最优值,一定会更新进答案。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#define N 300
using namespace std;
int a[N],f[N][N][N],n;
int main()
{
	freopen("248.in","r",stdin);
	freopen("248.out","w",stdout);
	scanf("%d",&n); int ans=0; int minn=40;
	for (int i=1;i<=n;i++) scanf("%d",&a[i]),ans=max(ans,a[i]),minn=min(minn,a[i]);
	memset(f,0,sizeof(f));
	for (int i=1;i<=n;i++) f[i][i][a[i]]=1;
	for (int len=2;len<=n;len++)
	 for (int i=1;i<=n;i++) {
	 	int pos=i+len-1;
	 	if (pos>n) break;
	 	int t=ans;
	 	for (int col=minn;col<=t;col++)
	 	{
	 	 for (int k=i;k<pos;k++)
	 	  if (f[i][k][col]&&f[k+1][pos][col]) {
		   f[i][pos][col+1]=1; ans=max(ans,col+1);
		   break;
	      }
	    }
	 }
	printf("%d\n",ans);
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值