165 - 数据类型判断

165 - 数据类型判断

Time Limit: 1000   Memory Limit: 65535
Submit: 378  Solved: 262

Description

从键盘分别输入通过空格分割的整型(int)、浮点型(double)、字符型(String)、布尔型(boolean),根据读取的内容判断他们的类型并将他们解析为正确的对象,并都放到一个数组中。输出各个对象的类型

Input

字符串

Output

数据类型

Sample Input

2.1 true 123 abcde

Sample Output

double boolean int String

HINT

 

Pre Append Code

Post Append Code
 

import java.util.Scanner;
import java.util.*;

public class Main {

    public static void main(String []args){

        Scanner scan = new Scanner(System.in);

        String s;

        int j=0;

        while(scan.hasNext()){

            if(j!=0)

                System.out.print(" ");

            if(scan.hasNextInt()){

                System.out.print("int");

            }

            else if(scan.hasNextDouble()){

                System.out.print("double");

            }

            else if(scan.hasNextBoolean()){

                System.out.print("boolean");

            }

            else System.out.print("String");

            scan.next();

            j=1;

        }

    }

}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值