POJ 3050 Hopscotch

Hopscotch
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2094 Accepted: 1504

Description

The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes. 

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited). 

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201). 

Determine the count of the number of distinct integers that can be created in this manner.

Input

* Lines 1..5: The grid, five integers per line

Output

* Line 1: The number of distinct integers that can be constructed

Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

Sample Output

15

Hint

OUTPUT DETAILS: 
111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.


思路:用的一个很暴力的解法,num[5][5]中每一个元素作为起点开始DFS,主要是想到用set,因为set装的是互不相同的元素,值得一提的是,今天才发现
string str;
str[0] = 'c'; //不报错
str[1] = 'c';//报错
原因想想也知道了,因为string定义时没有初始化,所以str[0]='c'的意思是把str 定义为c ;当你用str[1]的时候,他是不知道str[1]是什么的,因为他把str[0]和str画等号了。
string str = "ABC";
str[0] = 'c'; //不报错
str[1] = 'c';//不报错
这时编译器知道str[0].str[1]分别对应着str中的'A','B',所以对他们赋值就不会报错了
(以上都是我自己认为的,有错误的话欢迎指出!)

#include <iostream>
#include <string>
#include <set>
//#include <fstream>
using namespace std;
void DFS(int i, int j, int time);
set <string> S;
int num[5][5];
string str_temp = "ABCDEF";
set<string>::iterator index;
int a[] = { -1, 0, 1, 0 }, b[] = { 0, 1, 0, -1 };
int main()
{
	//ifstream in;
	//in.open("C://a.txt");
	for (int i = 0; i < 5; i++)
	for (int j = 0; j < 5; j++)
		cin >> num[i][j];
	for (int i = 0; i < 5; i++)
	for (int j = 0; j < 5; j++){
		DFS(i, j, 0);
	}
	cout << S.size();
	//in.close();
}
void DFS(int i, int j, int time){
	if (time == 6){
		S.insert(str_temp);
		/*for (int k = 0; k < 6;k++)
			cout << (int)str_temp[k] ;
			cout << endl;*/
		return;
	}
	for (int dx = 0; dx <= 3; dx++) {
		// 向x方向移动dx,向y方向移动dy,移动的结果为( nx,ny)
		if (i + a[dx] >= 0 && i + a[dx] < 5 && j + b[dx] >= 0 && j + b[dx] < 5){
			str_temp[time] = num[i + a[dx]][j + b[dx]];
			DFS(i + a[dx], j + b[dx], time + 1);
		}
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值