poj 1001 java大数类

16 篇文章 0 订阅

今天在地大邀请赛中,A题是大数题,java大数类不会用,c++大数模板写的不熟练,就懒得写,结果,只得了三等奖。。。

今天恶补下:

import java.math.BigDecimal;
import java.util.Scanner;
import java.math.BigInteger;
public class Math {

	/**
	 * @param args
	 */
	private static final int  DEFAULT_DIV_SCALE = 10;
	
	public static void main(String[] args) {
		// TODO Auto-generated method stub
	/*while(true)
	{
		Scanner input = new Scanner(System.in);
		int num = input.nextInt();
		System.out.println(num);	 
	}*/
		//BigInteger x = new BigInteger(44444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444111");
	//	BigInteger y = new BigInteger ("-555555555555555555555555555555555555555555");
		int m = 1233;
		BigInteger x = new BigInteger("12422333332222222222223443211");
		BigInteger y = new BigInteger ("12");
		BigInteger k = new BigInteger("e",16);
        System.out.println(k);
		System.out.println(x.add(y));
		System.out.println(y.abs());
	    System.out.println(y.compareTo(x));
	    BigInteger n = x.divide(y.abs());
		System.out.println(n);
		System.out.println(n.multiply(y.abs()));
		System.out.println(y.gcd(x));
		System.out.println(x.gcd(y));
		System.out.println(x.subtract(y));
		System.out.println(x.pow(m));
		/*System.out.print("输入数据:\n");
		System.out.println("输入数据:");
		Scanner  input = new Scanner(System.in);
		float num = input.nextFloat();
		System.out.println(num);*/
		System.out.println("大数求余:");
		System.out.println(x.mod(y));
		BigDecimal a = new BigDecimal("11111111.213211");
		System.out.println("a="+a);
		/*BigInteger b = new BigInteger ("11111111.213211");*/
		BigInteger b = new BigInteger ("11111111");
		System.out.println("b="+b);
		BigDecimal c = new BigDecimal("12222.121");
		System.out.println("c=="+c);
		System.out.println("a+c="+a.add(c));
	}
	
	
	
	}


题目链接:http://poj.org/problem?id=1001

第一次写java代码,交了一次没过,桑心。。。要做Codeforces了,有空补上

poj100题,留图纪念、、、、、、、、、、、、


记得,poj提交java类名都要换成Main的啊

import java.math.BigInteger;
import java.math.BigDecimal;
import java.util.Scanner;
import java.io.*;  //不知道这些包导入的对不?
public class Exponentiation {

	/**
	 * @param args
	 */
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner input = new Scanner(System.in);
		/*读入:
		 * 用Scanner 类定义的对象进行控制台读入,Scanner类在java.util.*包中
		 * Scanner input = new Scanner(System.in);
		 * int n = input.nextInt();
		 * BigInteger nn = input.nextBigInteger();
		 * ......................................
		 */
		while (input.hasNext())   //等同于!= EOF
		{
			int n;
			BigDecimal a = input.nextBigDecimal(); //读入一个BigDecimal
			n = input.nextInt();
			a = a.pow(n);  // 返回其值为 (thisn) 的 BigDecimal,准确计算该幂,使其具有无限精度。
			//pow(int n, MathContext mc)   返回其值为 (thisn) 的 BigDecimal。
			a = a.stripTrailingZeros();
			/*public BigDecimal stripTrailingZeros  (strip 脱去剥夺,trailing(拖尾,后面的))
			 * 返回数值上等于此小数,但表示形式溢出所有尾部0的BigDecimal
			 * 1.22222300000   用过之后为1.222223 类型还是BigDeciaml类型
			 */
			String str = a.toPlainString();
			/*
			 * 注意toPlainString()和toString()的区别
			 * 对于:BigDecimal s; s = (0.4321^20)
			 * String str = s.toPlainString();
			 * System.out.println(str);
			 * 输出:0.0000000514855464107。。。。。01
			 * 
			 *若String str = s.toString();
			 *输出为: 5.14855464107。。。。01E-8
			 */
			if (str.startsWith("0.")) //以什么开始
			{
				str = str.substring(1);
				/*substring是java中截取字符串的一个方法
				 * 有两种传参方式
				 * 一种是:public String substring(int deginindex)
				 * 返回一个新的字符串,它是此字符串的一个子串,该字串从指定索引处的字符开始直到字符串末尾
				 * 另一种是public String substring(int deginindex,int endindex)
				 * 返回一个新字符串,也是它的一个子串。该字串从beginindex处开始
				 * 直到索引到endindex-1处的字符。因此该字符串的长度为endindex-beginindex
				 * 
				 * 
				 * substr
				 * 该方法用于返回一个从指定位置开始的指定长度的子字符串
				 *substr(start,length);
				 */
			}
			System.out.println(str);
		}
	}
	}

java提交果然慢,100多ms

很好很好的资源:http://man.ddvip.com/program/java_api_zh/java/math/BigDecimal.html#stripTrailingZeros()

http://www.chineselinuxuniversity.net/articles/50293.shtml

http://wenku.baidu.com/view/9463cec7aa00b52acfc7caa8.html


坚持啊啊啊

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 4
    评论
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25. 输入说明 The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9. 输出说明 The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer. 输入样例 95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12 输出样例 548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201 小提示 If you don't know how to determine wheather encounted the end of input: s is a string and n is an integer C++ while(cin>>s>>n) { ... } c while(scanf("%s%d",s,&n)==2) //to see if the scanf read in as many items as you want /*while(scanf(%s%d",s,&n)!=EOF) //this also work */ { ... } 来源 East Central North America 1988 北大OJ平台(代理
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值