GCD hdu 2588

Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
 

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
 

Output
For each test case,output the answer on a single line.
 

Sample Input
 
 
3 1 1 10 2 10000 72
 

Sample Output
 
 
1 6 260
 

Source

题意:给出两个整数n和m,求使gcd(x,n)>=m的x的个数,

思路:假设i=x/gcd(x,n),j=n/gcd(x,n),可以看出i、j互质。我们要求的就是i、j的总共有多少对。也就是说求与j小于j并且与j互质的数的个数。

拿样例来说:

第一个中,1的约数只有1,ans=euler(1/1);

第二个样例中,10的约数有1、2、5、10,ans=euler(10/2)+euler(10/5)+euler(10/10);

第三个样例就不说了,太多了。

最开始直接枚举n的约数的话就超了,所以选择sqrt(n)内枚举,找到一个 i 使n%i==0就相当于找到2个n的约数了。

不要问我为什么不用欧拉筛法,因为n的取值范围太大·······

代码:

#include<stdio.h>
#include<math.h>
int euler(int n)
{
    int res=n;
    for(int i=2; i<=n; i++)
    {
        if(n%i==0)
        {
            res=res/i*(i-1);
            while(n%i==0)
                n/=i;
        }
    }
    if(n>1)
        res=res/n*(n-1);
    return res ;
}
int main()
{
    int t,n,m,ans;
    scanf("%d",&t);
    while(t--)
    {
        ans=0;
        scanf("%d %d",&n,&m);
        for(int i=1; i<=sqrt(n); i++)//写成sqrt(n)的话是为了不超时~ 就比如10=2*5,我们知道一个数是2了,那5肯定也知道了,就可以少循环一点了
        {
            if(n%i==0)
            {
                if(i>=m)
                    ans+=euler(n/i);
                if(n/i>=m&&i*i!=n)
                    ans+=euler(i);
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值