BZOJ 3942: [Usaco2015 Feb]Censoring KMP

3942: [Usaco2015 Feb]Censoring

Time Limit: 10 Sec  Memory Limit: 128 MB
Submit: 476  Solved: 260
[Submit][Status][Discuss]

Description

Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty of material to read while waiting around in the barn during milking sessions. Unfortunately, the latest issue contains a rather inappropriate article on how to cook the perfect steak, which FJ would rather his cows not see (clearly, the magazine is in need of better editorial oversight).

FJ has taken all of the text from the magazine to create the string S of length at most 10^6 characters. From this, he would like to remove occurrences of a substring T to censor the inappropriate content. To do this, Farmer John finds the _first_ occurrence of T in S and deletes it. He then repeats the process again, deleting the first occurrence of T again, continuing until there are no more occurrences of T in S. Note that the deletion of one occurrence might create a new occurrence of T that didn't exist before.

Please help FJ determine the final contents of S after censoring is complete

有一个S串和一个T串,长度均小于1,000,000,设当前串为U串,然后从前往后枚举S串一个字符一个字符往U串里添加,若U串后缀为T,则去掉这个后缀继续流程。

 
 

Input

The first line will contain S. The second line will contain T. The length of T will be at most that of S, and all characters of S and T will be lower-case alphabet characters (in the range a..z).
 
 

Output

The string S after all deletions are complete. It is guaranteed that S will not become empty during the deletion process.
 
 

Sample Input

whatthemomooofunmoo

Sample Output

whatthefun

有两个S和T,有一空串U,然后从前往后枚举S串一个字符一个字符往U串里添加

若U串后缀为T,则去掉这个后缀继续流程。

很明显需要字符串匹配

如果每一次匹配成功就删掉 并重新匹配

复杂度会被卡成O(n^2)

所以呢

用一个栈来维护

只要记录一下每个字符被访问到时所匹配的长度即可

一旦被删除,只需要把已匹配数更新一下就好

复杂度重回线性

PS:

记得这题是当年ahcisy讲的例题。。。然而懒BJ怎么会去找,况且我当时不会。。。

今天开爷讲字符串

又有这个题,想了一想

wa我竟然会诶

#include<cmath>
#include<ctime>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<complex>
#include<iostream>
#include<algorithm>
#include<iomanip>
#include<vector>
#include<string>
#include<queue>
#include<set>
#include<map>
using namespace std;
typedef double db;
inline int read()
{
	int x=0,f=1;char ch=getchar();
	while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
	while(ch<='9'&&ch>='0'){x=(x<<1)+(x<<3)+ch-'0';ch=getchar();}
	return x*f;
}
const int N=1000100;
int nt[N],pre[N];
char a[N],b[N],c[N];
int main()
{
	scanf("%s%s",a,b);
	int len=strlen(b);
	for(int i=1,j;i<len;i++)
	{
		j=nt[i];
		while(j&&b[i]!=b[j])j=nt[j];
		if(b[i]==b[j])nt[i+1]=j+1;
		else nt[i+1]=0;
	}
	int n=strlen(a);int top=-1;
	for(int i=0,j=0;i<n;i++)
	{
		c[++top]=a[i];
		while(j&&a[i]!=b[j])j=nt[j];
		if(a[i]==b[j])j++;else j=0;
		pre[top]=j;
		if(j==len)
		{j=pre[top-len];top=top-len;}
	}
	c[top+1]='\0';puts(c);
	return 0;
}
/*
whatthemomooofun
moo

whatthefun
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值