Leftmost Digit HDU1060

题目:

Given a positive integer N, you should output the leftmost digit of N^N. 

输入:

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case contains a single positive integer N(1<=N<=1,000,000,000). 

输出:

For each test case, you should output the leftmost digit of N^N. 

样例输入:

2
3
4

样例输出:

2
2

提示:

In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.

 题目意思很明了,找到n^n最左边那位数字是什么。

首先我们把n^n用科学计数法表示出来,n^n=a*10^x,这里的a就是我们要求的数,例如4^4=256=2.56*10^2,a为2。

两边取对数,lg(n^n)=lg(a*10^x),变一下形,nlg(n)=lg(a)+xlg(10)=lg(a)+x

a=10^(nlg(n)-x).

接下来把x求出来a也就出来了,x其实就是n^n的位数-1,求一个数的位数通常是对它取对数,向下取整后加一。例如:(int)lg(256)+1=3。所以x=(int)lg(n^n)。

#include <bits/stdc++.h>

using namespace std;

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        long long n;
        cin>>n;
        double x=log10((double)n)*n;
        int a=pow(10,x-(long long)x);
        cout<<a<<"\n";
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值