Hdu 1051(贪心思想)

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16513    Accepted Submission(s): 6780


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
  
  
2 1

3

/********************************************************/

//非常典型的贪心题,思路就是尽量让小的length排在前面,相同length按照weight来排列

//这样得到的序列中,后一个length必定大于当前的length,再根据weight的大小来选择是

//否要改变序列

源代码如下:

#include <iostream>
using namespace std;

const int N=5001;

struct ticket
{
	int length, weight;
	int flag;
}T[N];

void Sort(int n)
{
	ticket temp;
	int i, j;
	for(i=0; i<n-1; i++)
	{
		for(j=i+1; j<n; j++)
		{
			if(T[j].length<T[i].length)
			{
				temp=T[i];
				T[i]=T[j];
				T[j]=temp;
			}
			if(T[j].length == T[i].length)
			{
				if(T[j].weight < T[i].weight)
				{
					temp=T[i];
					T[i]=T[j];
					T[j]=temp;
				}
			}
		}
	}
	bool flag=false;
	int scout=-1, weight;
	while(!flag)
	{
		flag=true;
		weight = 0; 
		scout++;
		for(i=0; i<n; i++)
		{
			if(!T[i].flag && T[i].weight>=weight)
			{
				T[i].flag=1;
				weight=T[i].weight;
				flag=false;
			}
		}
	}
	cout<<scout<<endl;
}

int main()
{
	int t, n, i;
	cin>>t;
	while(t--)
	{
		cin>>n;
		for(i=0; i<n; i++)
		{
			cin>>T[i].length>>T[i].weight;
			T[i].flag=0;
		}
		Sort(n);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值