HDU ACM 1051 Wooden Sticks

原题描述

Problem Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l’ and weight w’ if l<=l’ and w<=w’. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, …, ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1

Sample Output

2
1
3

解题思路

题意:有一堆木头,有长度l和重量w属性。需要用机器进行处理,开始时机器需要1分钟准备时间,处理一个木头以后,如果下一个木头的长度和重量都大于等于处理的木头,那么不需要准备时间,否则需要1分钟准备时间。求最少准备时间。
按长度和重量不同优先级从大到小排序,然后从重量大的开始扫描(扫描一次即为准备时间+1),如果遇到长度比这根长的,跳过,如果遇到长度比这根短,标记为处理过并且将最短长度设为该木头的长度。

参考代码

#include <iostream>
#include <algorithm>
using namespace std;

struct wood
{
    int l, w, flag;             // 增加flag标旗,0表示未处理,1表示已处理
}W[5001];

bool cmp(wood a,wood b)         // 长度长的放前面,如果长度一样,重量重的放前面
{
    return a.l != b.l ? a.l > b.l : a.w > b.w;
}

int main()
{
    int t, n, ans, min;
    cin >> t;
    while(t--)
    {
        ans = 0;
        cin >> n;
        for (int i = 0; i < n;i++)
        {
            cin >> W[i].l >> W[i].w;
            W[i].flag = 0;
        }
        sort(W, W + n, cmp);                // 长度长的排前面,反向枚举


        for (int i = 0; i < n;i++)
        {
            if (W[i].flag == 1)
                continue;
            ans++;
            W[i].flag = 1;                  // 开始第一趟枚举
            min = W[i].w;                   // 标记当前的木头重量
            for (int j = i + 1; j < n; j++)
            {
                if (W[j].w <= min && W[j].flag == 0)    // 与之后的比较重量,如果重量小于前一个,那标记为已处理,并且赋值给min
                {
                    min = W[j].w;
                    W[j].flag = 1;
                }
            }
        }
        cout << ans << endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值