约瑟夫问题——循环链表

think:
1顺序建立循环链表+循环链表中的符合题意的元素结点的删除
2注意只有一个人玩死亡游戏的情况

sdut原题链接

约瑟夫问题
Time Limit: 1000MS Memory Limit: 65536KB

Problem Description
n个人想玩残酷的死亡游戏,游戏规则如下:
n个人进行编号,分别从1到n,排成一个圈,顺时针从1开始数到m,数到m的人被杀,剩下的人继续游戏,活到最后的一个人是胜利者。
请输出最后一个人的编号。

Input
输入n和m值。

Output
输出胜利者的编号。

Example Input
5 3

Example Output
4

Hint
第一轮:3被杀第二轮:1被杀第三轮:5被杀第四轮:2被杀

Author

以下为accepted代码1

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int Data;
    struct node *next;
}*head, *tail;
void Build(int n);//顺序建立循环链表
void Search_ans(struct node *h, int m);//循环链表中删除满足题意的元素结点
int main()
{
    int n, m;
    while(scanf("%d %d", &n, &m) != EOF)
    {
        if(n == 1)
            printf("%d\n", n);
        else
        {
            head = (struct node *)malloc(sizeof(struct node));
            head->Data = 1;//循环链表中头结点不再为空
            head->next = NULL;
            tail = head;
            Build(n);//顺序建立循环链表
            Search_ans(head, m);//循环链表中删除满足题意的元素结点
        }
    }
    return 0;
}
void Build(int n)//顺序建立循环链表
{
    struct node *p;
    for(int i = 2; i < n; i++)
    {
        p = (struct node *)malloc(sizeof(struct node));
        p->Data = i;
        p->next = tail->next;
        tail->next = p;
        tail = p;
    }
    p = (struct node *)malloc(sizeof(struct node));
    p->Data = n;
    tail->next = p;
    p->next = head;
}
void Search_ans(struct node *h, int m)//在循环链表中删除满足题意的元素结点
{
    int cnt = 0;
    struct node *q, *p;
    q = tail->next;
    p = head;
    while(p->next != p)
    {
        cnt++;
        if(cnt % m == 0)
        {
            q->next = p->next;
            free(p);
            p = q->next;
        }
        else
        {
            q = p;
            p = p->next;
        }
    }
    printf("%d\n", p->Data);
}


/***************************************************
User name: 
Result: Accepted
Take time: 0ms
Take Memory: 108KB
Submit time: 2017-03-10 21:04:59
****************************************************/

以下为accepted代码2

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int Data;
    struct node *next;
}*head, *tail;
void Build(int n);//顺序建立循环链表
void Search_ans(struct node *h, int m);//循环链表中删除满足题意的元素结点
int main()
{
    int n, m;
    while(scanf("%d %d", &n, &m) != EOF)
    {
        head = (struct node *)malloc(sizeof(struct node));
        head->Data = 1;//循环链表中头结点不再为空
        head->next = NULL;
        tail = head;
        Build(n);//顺序建立循环链表
        Search_ans(head, m);//循环链表中删除满足题意的元素结点
    }
    return 0;
}
void Build(int n)//顺序建立循环链表
{
    struct node *p;
    for(int i = 2; i < n; i++)
    {
        p = (struct node *)malloc(sizeof(struct node));
        p->Data = i;
        p->next = tail->next;
        tail->next = p;
        tail = p;
    }
    if(n != 1)
    {
        p = (struct node *)malloc(sizeof(struct node));
        p->Data = n;
        tail->next = p;
        p->next = head;
    }
    else
    {
        head->next = head;
    }
}
void Search_ans(struct node *h, int m)//在循环链表中删除满足题意的元素结点
{
    int cnt = 0;
    struct node *q, *p;
    q = tail->next;
    p = head;
    while(p->next != p)
    {
        cnt++;
        if(cnt % m == 0)
        {
            q->next = p->next;
            free(p);
            p = q->next;
        }
        else
        {
            q = p;
            p = p->next;
        }
    }
    printf("%d\n", p->Data);
}


/***************************************************
User name: 
Result: Accepted
Take time: 0ms
Take Memory: 108KB
Submit time: 2017-03-10 21:06:48
****************************************************/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值