数据结构实验之链表七:单链表中重复元素的删除

think:
1逆序建立单链表+使用三个指针进行单链表中重复元素的遍历删除

sdut原题链接

数据结构实验之链表七:单链表中重复元素的删除
Time Limit: 1000MS Memory Limit: 65536KB

Problem Description
按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

Input
第一行输入元素个数 n (1 <= n <= 15);
第二行输入 n 个整数,保证在 int 范围内。

Output
第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。

Example Input
10
21 30 14 55 32 63 11 30 55 30

Example Output
10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21

Hint
不得使用数组!

Author

以下为accepted代码

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstdlib>

using namespace std;

struct node
{
    int Data;
    struct node *next;
}*head;

int cnt;

void Build(int n);
void Delete(struct node *h);
void Pri(struct node *h);

int main()
{
    int n;
    while(scanf("%d", &n) != EOF)
    {
        cnt = 0;
        head = (struct node *)malloc(sizeof(struct node));
        head->next = NULL;
        Build(n);
        printf("%d\n", n);
        Pri(head);

        Delete(head);
        printf("%d\n", n-cnt);
        Pri(head);
    }
}
void Build(int n)
{
    struct node *p;
    for(int i = 0; i < n; i++)
    {
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d", &p->Data);
        p->next = head->next;
        head->next = p;
    }
}
void Pri(struct node *h)
{
    struct node *p;
    p = h->next;
    while(p != NULL)
    {
        printf("%d%c", p->Data, p->next == NULL? '\n': ' ');
        p = p->next;
    }
}
void Delete(struct node *h)
{
    struct node *t, *q, *p;
    t = h->next;
    while(t != NULL)
    {
        q = t;
        p = NULL;
        if(t->next != NULL)
            p = t->next;
        while(p != NULL)
        {
            if(t->Data == p->Data)
            {
                q->next = p->next;
                free(p);
                p = q->next;
                cnt++;
            }
            else
            {
                q = p;
                p = p->next;
            }
        }
        t = t->next;
    }
}


/***************************************************
User name: 
Result: Accepted
Take time: 0ms
Take Memory: 152KB
Submit time: 2017-03-28 21:38:00
****************************************************/
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值