B - Dungeon Master——广度优先搜索

Think:
1错误反思:已入队过结点不要忘记标记+数组不要越界
2知识点:广度优先搜索+队列思想

B - Dungeon Master
You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.
Is an escape possible? If yes, how long will it take?
Input
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#’ and empty cells are represented by a ‘.’. Your starting position is indicated by ‘S’ and the exit by the letter ‘E’. There’s a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form

    Escaped in x minute(s). 


where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line

    Trapped! 

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

以下为Runtime Error代码——数组越界

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>

using namespace std;

struct node
{
    int x;
    int y;
    int z;
    int num;
} link[40000];

int op, tp, l, m, n, flag, ans;
int v[44][44][44];///标记当前结点是否入队过
char st[44][44][44];///记录原始输入数据
int jk[6][3] = {
  {
  0, 1, 0}, {
  1, 0, 0}, {
  0, -1, 0}, {-1, 0, 0}, {
  0, 0, -1}, {
  0, 0, 1}};
///jk数组实现6个移动方向

void BFS();
bool Judge(int dz, int dx, int dy);

int main()
{
    int i, j, k;
    while(scanf("%d %d %d", &l, &m, &n) && (l != 0 || n != 0 || m != 0))
    {
        ///getchar();///吸收回车符
        op = tp = flag = 0;
        memset(v, 0, sizeof(v));
        for(i = 0; i < 400000; i++)///Runtime Error:数组越界
            link[i].num = 0;
        for(i = 0; i < l; i++)
        {
            for(j = 0; j < m; j++)
            {
                scanf("%s", st[i][j]);
                ///getchar();///吸收回车符
            }
            ///getchar();///吸收回车符
        }
        
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值