Think:
1洗牌,从st1和st2的底部开始,每次将st1放在st2上面,如果合并后与st相同,记录当前次数,然后结束,如果合并后不相同,取新的st下半部作为新的st1,取新的st上半部作为新的st2,模拟过程发现洗牌2*c次st1,st2会回到最初状态.
2题意是大于等于0次,因此自己认为最初需判断是否可以直接累加st1和st2得到st,自己注释掉最初判断0次的情况,仍然Accepted,但个人认为应该加上判断0次的情况
3注意新的字符串加上字符串结束标志,然后调用strcmp()函数判断两个字符串是否相同
N - Shuffle’m Up POJ - 3087
A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.
The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:
The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.
After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.
For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.
Input
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.
Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.
Output
Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.
Sample Input
2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC
Sample Output
1 2
2 -1
以下为Accepted代码——建议参考
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
char st1[104], st2[104], st[208], ans[208];
int T, c, n, k, kk, i, t, v;
scanf("%d", &T);
for(k = 1; k <= T; k++)
{
scanf("%d", &c);
getchar();
scanf("%s", st1);
scanf("%s", st2);
scanf("%s", st);
v = -1;
t = 0;
for(i = 0; i < c; i++)
{
ans[t++] = st1[i];
}
for(i = 0; i < c; i++)
{
ans[t++] = st2[i];
}
ans[t] = '\0';///字符串结束的标志
if(strcmp(ans, st) == 0)
v = 0;
if(v == -1)
{
t = 0;
for(i = 0; i < c; i++)
{
ans[t++] = st2[i];
}
for(i = 0; i < c; i++)
{
ans[t++] = st1[i];
}
ans[t] = '\0';///字符串结束的标志
if(strcmp(ans, st) == 0)
v = 0;
}
if(v == -1)
{
n = 2*c;
for(kk = 1; kk <= n; kk++)
{
t = 0;
for(i = 0; i < c; i++)
{
ans[t++] = st2[i];
ans[t++] = st1[i];
}
ans[t] = '\0';///字符串结束的标志
if(strcmp(ans, st) == 0)
{
v = kk;
break;
}
for(i = 0; i < c; i++)
{
st1[i] = ans[i];
}
for(i = c; i < t; i++)
{
st2[i-c] = ans[i];
}
}
}
printf("%d %d\n", k, v);
}
return 0;
}
以下为Accepted代码
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
char st1[104], st2[104], st[208], ans[208];
int T, c, n, k, kk, i, t, v;
scanf("%d", &T);
for(k = 1; k <= T; k++)
{
scanf("%d", &c);
getchar();
scanf("%s", st1);
scanf("%s", st2);
scanf("%s", st);
v = -1;
t = 0;
/*for(i = 0; i < c; i++)
{
ans[t++] = st1[i];
}
for(i = 0; i < c; i++)
{
ans[t++] = st2[i];
}
ans[t] = '\0';///字符串结束的标志
if(strcmp(ans, st) == 0)
v = 0;
if(v == -1)
{
t = 0;
for(i = 0; i < c; i++)
{
ans[t++] = st2[i];
}
for(i = 0; i < c; i++)
{
ans[t++] = st1[i];
}
ans[t] = '\0';///字符串结束的标志
if(strcmp(ans, st) == 0)
v = 0;
}*/
if(v == -1)
{
n = 2*c;
for(kk = 1; kk <= n; kk++)
{
t = 0;
for(i = 0; i < c; i++)
{
ans[t++] = st2[i];
ans[t++] = st1[i];
}
ans[t] = '\0';///字符串结束的标志
if(strcmp(ans, st) == 0)
{
v = kk;
break;
}
for(i = 0; i < c; i++)
{
st1[i] = ans[i];
}
for(i = c; i < t; i++)
{
st2[i-c] = ans[i];
}
}
}
printf("%d %d\n", k, v);
}
return 0;
}