模拟-Shuffle'm Up POJ - 3087

模拟-Shuffle’m Up POJ - 3087

题目:
A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

Input
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

Output
Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

Sample Input
2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC
Sample Output
1 2
2 -1

题意
输入两个长度为C的字符串s1,s2和一个长度为2C的字符串s3,将s1插空到s2中去(比如,s1=“abc”,s2=“def”,插空得到新字符串tmp=“daebfc”),接着将临时变量tmp的前一半赋给s2,后一半赋给s1(若tmp=“daebfc”,则s2=“dae”,s1=“bfc”),重复操作,问最少需要操作多少次,能够使得s2+s1和s3相等,若不能则输出-1。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
using namespace std;
const int maxn=1e4;
int T;
int n;
string s1,s2,s3,temp;
map<string,int> vis;//标记当前合并后的情况是否出现过,避免死循环
int ans;
int main()
{
	cin>>T;
	for(int k=1;k<=T;k++)
	{
		vis.clear();
		ans=0;
		cin>>n;
		cin>>s1>>s2>>s3;

		while(1)
		{
			temp.clear();
			for(int i=0;i<n;i++)//先插空合并
			{
				temp.push_back(s2[i]);
				temp.push_back(s1[i]);
			}
			ans++;
			if(temp==s3)
				break;
			if(!vis[temp])//更新s1,s2
			{
				vis[temp]=1;
				s1.clear();
				s2.clear();
				for(int i=0;i<n;i++)
					s1.push_back(temp[i]);
				for(int i=n;i<2*n;i++)
					s2.push_back(temp[i]);

			}
			else
			{
				ans=-1;
				break;
			}

		}
		printf("%d %d\n",k,ans);
	}
	return 0;
}

总结:

  1. string类插入函数:push_back() 和 insert()
void  test()
{
    string s1;

    // 尾插一个字符
    s1.push_back('a');
    s1.push_back('b');
    s1.push_back('c');
    cout<<"s1:"<<s1<<endl; // s1:abc

    // insert(pos,char):在制定的位置pos前插入字符char
    s1.insert(s1.begin(),'1');
    cout<<"s1:"<<s1<<endl; // s1:1abc
}
  1. map的使用
    vis[string temp]=1;代表string temp已出现过
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值