Radar Installation - POJ 1328 贪心

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 58694 Accepted: 13213

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1


题意:每个雷达能监控距离为d的区域,在坐标平面上有若干个小岛,问最少要用多少个雷达才能监控所有的小岛。如果不能监控所有的小岛,输出-1


思路,每个小岛给出坐标后,雷达的可能区域在x轴上对应一个线段,所求的便是最少有多少个点可以使每条线段都至少覆盖一个点。先对线段的起始点进行升序排序,每次遍历检查是否与之前的区间有交集,有的话对区域求交,没有的话cnt++并记录新的区间。


#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
#include<cmath>
#define MAXN 1010
using namespace std;
struct node
{
	double s,e;
}island[MAXN];
bool cmp (node a, node b)
{
	if(a.s==b.s) return a.e>b.e;
	else
		return a.s<b.s;
}
int main(){
//	freopen("in.txt","r",stdin);
	int n,dd,kas=0;
	double d,ss;
	while(scanf("%d%d",&n,&dd),n||dd){
		d=dd;
		int cnt=1;
		double x,y;
		for(int i=1;i<=n;i++){
			scanf("%lf%lf",&x,&y);
			if(fabs(y)>d) cnt=-1;
			island[i].s=x-sqrt(d*d-y*y);
			island[i].e=x+sqrt(d*d-y*y);
		}
		sort(island+1,island+1+n,cmp);
		double l=island[1].s,r=island[1].e;
		if(cnt!=-1)
			for(int i=2;i<=n;i++){
				if(island[i].s>r){
					cnt++;
					l=island[i].s;
					r=island[i].e;
				}else {
					l=max(l,island[i].s);
					r=min(r,island[i].e);
				}
				
			}
		printf("Case %d: %d\n",++kas,cnt);
	}
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据您的问题,我理解您想了解POJ1328问题的Java解决方案。POJ1328是一个经典的问题,也被称为"雷达安装"问题,它涉及到在一个二维平面上安装雷达以覆盖所有岛屿的最小雷达数量。以下是一个Java解决方案的示例代码: ```java import java.util.Arrays; import java.util.Comparator; import java.util.Scanner; public class Main { public static void main(String[] args) { Scanner scanner = new Scanner(System.in); int caseNum = 1; while (true) { int n = scanner.nextInt(); if (n == 0) { break; } Island[] islands = new Island[n]; for (int i = 0; i < n; i++) { int x = scanner.nextInt(); int y = scanner.nextInt(); islands[i] = new Island(x, y); } int radarNum = getRadarNum(islands); System.out.println("Case " + caseNum + ": " + radarNum); caseNum++; } } private static int getRadarNum(Island[] islands) { Arrays.sort(islands, Comparator.comparingInt(Island::getRight)); int radarNum = 1; int rightMost = islands[0].getRight(); for (int i = 1; i < islands.length; i++) { if (islands[i].getLeft() > rightMost) { radarNum++; rightMost = islands[i].getRight(); } else { rightMost = Math.min(rightMost, islands[i].getRight()); } } return radarNum; } static class Island { private int left; private int right; public Island(int left, int right) { this.left = left; this.right = right; } public int getLeft() { return left; } public int getRight() { return right; } } } ``` 这段代码通过输入岛屿的坐标,计算出需要安装的最小雷达数量,并输出结果。它使用了排序和贪心算法的思想来解决问题。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值