POJ--1328--Radar Installation--贪心好题

题目链接:http://poj.org/problem?id=1328

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.


Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output
Case 1: 2
Case 2: 1

思路:建立雷达结构体坐标+贪心+线段交集+处理最少的情况.

#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
const int maxn=1010;
struct Island{
	double left, right;
}isl[maxn];
bool operator<(const Island &a, const Island &b){
	return a.left<b.left; //升序
}
int n, d, x, y;
int solve(){
	sort(isl+1, isl+1+n); //按左端点大小升序排列//若当前线段与目前集合中的线段没有交集, 则加入新的雷达
	double range = isl[1].right;
	int ans=1;
	for(int i = 2; i <= n; i++){
		if(isl[i].left <= range) 
			range = min(range, isl[i].right);
		else{ 
			range = isl[i].right; 
			ans++;
		} 
	}
	return ans;
}
int main(){
	int k=1;
	while(1){//n表示具体的点的个数,d表示覆盖距离 
		cin>>n>>d;
		if(n==0&&d==0)
			break; 
		bool flag = 1;
		for(int i = 1; i <= n; i++){ 
			scanf("%d%d",&x,&y); //输入具体的坐标 
			if(y>d) 
				flag = 0;//此处可以决定输出,即不可能实现的情况 
			isl[i].left = x*1.0-sqrt(d*d-y*y); //计算每个小岛决定的雷达范围(反向思考) 
			isl[i].right = x*1.0+sqrt(d*d-y*y); //勾股定理
		}
	if(flag) 
	//对于solve()函数的书写十分简单 
		cout<<"Case "<<k++<<": "<<solve()<<endl;//printf("Case %d: %d\n",k++, solve());
	else 
		cout<<"Case "<<k++<<": -1"<<endl;//printf("Case %d: -1\n",k++); //不可能实现的情况 
	}
}
/*Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output
Case 1: 2
Case 2: 1*/ 

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值