8583 顺序栈的基本操作

8583 顺序栈的基本操作

时间限制:1000MS 代码长度限制:10KB
提交次数:4189 通过次数:2059

题型: 编程题 语言: G++;GCC

Description 创建一个空的顺序栈,并实现栈的入栈、出栈、返回栈的长度、返回栈顶元素、栈的遍历等基本算法。请将下面的程序补充完整。

输入格式

测试样例格式说明:
根据菜单操作:
1、输入1,表示要实现Push操作,紧跟着输入要Push的元素
2、输入2,表示要实现Pop操作
3、输入3,返回栈顶元素
4、输入4,返回栈的元素个数
5、输入5,表示从栈顶到栈底输出栈的所有元素
6、输入0,表示程序结束

输入样例

1
2
1
4
1
6
5
3
4
2
5
2
2
2
0

输出样例

A Stack Has Created.
1:Push
2:Pop
3:Get the Top
4:Return the Length of the Stack
5:Load the Stack
0:Exit
Please choose:
The Element 2 is Successfully Pushed!
1:Push
2:Pop
3:Get the Top
4:Return the Length of the Stack
5:Load the Stack
0:Exit
Please choose:
The Element 4 is Successfully Pushed!
1:Push
2:Pop
3:Get the Top
4:Return the Length of the Stack
5:Load the Stack
0:Exit
Please choose:
The Element 6 is Successfully Pushed!
1:Push
2:Pop
3:Get the Top
4:Return the Length of the Stack
5:Load the Stack
0:Exit
Please choose:
The Stack is: 6 4 2
1:Push
2:Pop
3:Get the Top
4:Return the Length of the Stack
5:Load the Stack
0:Exit
Please choose:
The Top Element is 6!
1:Push
2:Pop
3:Get the Top
4:Return the Length of the Stack
5:Load the Stack
0:Exit
Please choose:
The Length of the Stack is 3!
1:Push
2:Pop
3:Get the Top
4:Return the Length of the Stack
5:Load the Stack
0:Exit
Please choose:
The Element 6 is Successfully Poped!
1:Push
2:Pop
3:Get the Top
4:Return the Length of the Stack
5:Load the Stack
0:Exit
Please choose:
The Stack is: 4 2
1:Push
2:Pop
3:Get the Top
4:Return the Length of the Stack
5:Load the Stack
0:Exit
Please choose:
The Element 4 is Successfully Poped!
1:Push
2:Pop
3:Get the Top
4:Return the Length of the Stack
5:Load the Stack
0:Exit
Please choose:
The Element 2 is Successfully Poped!
1:Push
2:Pop
3:Get the Top
4:Return the Length of the Stack
5:Load the Stack
0:Exit
Please choose:
Pop Error!
1:Push
2:Pop
3:Get the Top
4:Return the Length of the Stack
5:Load the Stack
0:Exit
Please choose:

下面展示一些 内联代码片

#define _CRT_SECURE_NO_WARNINGS
#include <stdio.h>
#include <iostream>
using namespace std;
#include<malloc.h> 
#define OK 1
#define ERROR 0
#define STACK_INIT_SIZE 100 // 存储空间初始分配量
#define STACKINCREMENT 10 // 存储空间分配增量

typedef int SElemType; // 定义栈元素类型
typedef int Status; // Status是函数的类型,其值是函数结果状态代码,如OK等

struct SqStack
{
	SElemType* base; // 在栈构造之前和销毁之后,base的值为NULL
	SElemType* top; // 栈顶指针
	int stacksize; // 当前已分配的存储空间,以元素为单位
}; // 顺序栈

Status InitStack(SqStack& S)
{
	// 构造一个空栈S,该栈预定义大小为STACK_INIT_SIZE
	// 请补全代码

//该栈栈底无数据,栈顶有数据
	S.base = new SElemType[STACK_INIT_SIZE];//new一个空栈数组,地址返回到S.base
	S.top = S.base;//空栈top和base相同
	S.stacksize = STACK_INIT_SIZE;//栈定义的大小STACK_INIT_SIZE给到stacksize
	return OK;
}

Status Push(SqStack& S, SElemType e)
{
	// 在栈S中插入元素e为新的栈顶元素
	// 请补全代码
	if (S.stacksize <= S.top - S.base) {//栈顶和栈底差值大于等于栈范围则栈满
		//栈满要先realloc扩大STACKINCREMENT再放入值
		S.base = (SElemType*)realloc(S.base, sizeof(SElemType) * (S.stacksize + STACKINCREMENT));
		if (S.base == NULL)return ERROR; else {
			//要先将新申请的栈S.base赋值给原来的S.top
			//S.top要在新栈S.base+原S.stacksize处
			S.top = S.base + S.stacksize;
			//再更新栈存储大小
			S.stacksize += STACKINCREMENT;
			//赋值到新S.top
			S.top++;
			*S.top = e;
		}
	}
	else {
		//栈没有满直接赋值
		S.top++;
		*S.top = e;
	}
	return OK;
}

Status Pop(SqStack& S, SElemType& e)
{
	// 若栈不空,则删除S的栈顶元素,用e返回其值,并返回OK;否则返回ERROR
	// 请补全代码

	//判断空栈
	if (S.top == S.base)return ERROR; else {
		//此处不用删除,用e存数据,将top移下一格即可
		e = *S.top;
		S.top--;
	}
		return OK;
}

Status GetTop(SqStack S, SElemType& e)
{
	// 若栈不空,则用e返回S的栈顶元素,并返回OK;否则返回ERROR
	// 请补全代码
	if (S.top == S.base)return ERROR; else {
		e = *S.top;
	}
	return OK;
}

int StackLength(SqStack S)
{
	// 返回栈S的元素个数
	// 请补全代码
	int length = 0;
	//栈顶指针减栈底指针即为长度
	length = S.top - S.base;
	return length;
}

Status StackTraverse(SqStack S)
{
	// 从栈顶到栈底依次输出栈中的每个元素
      //请填空
		if (S.top==S.base)printf("The Stack is Empty!"); //请填空
		else
		{
			printf("The Stack is: ");
			//找到顺序栈长度
			int length = S.top - S.base;
			//用栈顶赋值到p
			SElemType* p = S.top;
			while (length--)            //请填空
			{
				               //请填空
				//向下递推
					printf("%d ", *p--);
			}
		}
	printf("\n");
	return OK;
}

int main()
{
	int a;
	SqStack S;
	SElemType x, e;
	if (InitStack(S))    // 判断顺序表是否创建成功,请填空
	{
		printf("A Stack Has Created.\n");
	}
	while (1)
	{
		printf("1:Push \n2:Pop \n3:Get the Top \n4:Return the Length of the Stack\n5:Load the Stack\n0:Exit\nPlease choose:\n");
		scanf("%d", &a);
		switch (a)
		{
		case 1: scanf("%d", &x);
			//注意  是!Push,下同
			if (!Push(S,x)) printf("Push Error!\n"); // 判断Push是否合法,请填空
			else printf("The Element %d is Successfully Pushed!\n", x);
			break;
		case 2: if (!Pop(S,e)) printf("Pop Error!\n"); // 判断Pop是否合法,请填空
			  else printf("The Element %d is Successfully Poped!\n", e);
			break;
		case 3: if (!GetTop(S,e))printf("Get Top Error!\n"); // 判断Get Top是否合法,请填空
			  else printf("The Top Element is %d!\n", e);
			break;
		case 4: printf("The Length of the Stack is %d!\n", StackLength(S)); //请填空
			break;
		case 5: StackTraverse(S);  //请填空
			break;
		case 0: return 1;
		}
	}
}
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值