POJ 3371

给出了一段话,求这段话里面单词的个数,句子的个数,音节的个数,然后带入到上面的公式中输出结果。
单词的个数很好查,scanf("%s")输入一个就是一个单词。
一个句子的标志是句号“.”、问号“?”、冒号“:”、分号“;”、感叹号“!”。出现了这些符号就sen++。
比较麻烦的在于音节的计算。
首先,如果一个单词的长度小于等于3,那么这个单词固定就是贡献了一个音节的数量。
如果长度大于3,那么单词中出现一个“a”“e”“i”“o”“u”“y”“A”“E”“I”“O”“U”“Y”,音节数就+1。但是连续出现的元音字母就只算一次,注意是连续出现,连续出现2次算一个,连续出现3次也只算一个。

如果一个单词的末尾是es、ed、e(除了le),那么忽略这些字符。

Flesch Reading Ease
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2275 Accepted: 715

Description

Flesch Reading Ease, a readability test named after its deviser Rudolf Flesch, is among most ubiquitously used readability tests, which are principally employed for assessment of the difficulty to understand a reading passage written in English. The Flesch Reading Ease score of a passage relies solely on three statistics, namely the total numbers of sentences, words and syllables, of the passage. Specifically, the score is defined by the following formula:

.

As can be inferred from the above formula, a passage with a high Flesch Reading Ease score tends to favor shorter sentences and words, which is in compliance with commonsense in spite of partial accuracy. (Think of, for instance, the word "television". Long as it may seem, it is indeed one of the first words that any individual who studies English learns.) A related Wikipedia entry on Flesch Reading Ease [1] suggests that passages scoring 90~100 are comprehensible for an average American 5th grader, and 8th and 9th graders possess the ability to follow passages with a score in the range of 60~70, whereas passages not exceeding 30 in the score are best suitable for college graduates. The text of this problem, all sections taken into account, scores roughly 50 as per the calculation of Google Documents.

Despite the simplicity in its ideas, several aspects of its definition remains vague for any real-world implementation of Flesch Reading Ease. For the sake of precision and uniformity, the following restrictions adapted from [2] are adopted for this problem, to which you are to write a solution that effectively computes the Flesch Reading Ease score of a given passage of English text.

  1. Periods, explanation points, colons and semicolons serve as sentence delimiters.
  2. Each group of continuous non-blank characters with beginning and ending punctuation removed counts as a word.
  3. Each vowel (one of a, e, i, o, u and y) in a word is considered one syllable subject to that
    1. -es, -ed and -e (except -le) endings are ignored,
    2. words of three letters or shorter count as single syllables,
    3. consecutive vowels count as one syllable.
References
  1. Wikipedia contributors. Flesch-Kincaid Readability Test. Wikipedia, The Free Encyclopedia. August 30, 2007, 01:57 UTC. Available at: http://en.wikipedia.org/w/index.php?title=Flesch-Kincaid_Readability_Test&oldid=154509512. Accessed September 5, 2007.
  2. Talburt, J. 1985. The Flesch index: An easily programmable readability analysis algorithm. In Proceedings of the 4th Annual international Conference on Systems Documentation. SIGDOC '85. ACM Press, New York, NY, 114-122.

Input

The input contains a passage in English whose Flesch Reading Ease score is to be computed. Only letters of the English alphabet (both lowercase and uppercase), common punctuation marks (periods, question and exclamation marks, colons, semicolons as well as commas, quotation marks, hyphens and apostrophes), and spaces appear in the passage. The passage is of indefinite length and possibly occupies multiple lines. Additionally, it is guaranteed to be correct in punctuation. 

Output

Output the Flesch Reading Ease score of the given passage rounded to two digits beyond decimal point. 

Sample Input

Flesch Reading Ease, a readability test named after its deviser Rudolf Flesch,
is among most ubiquitously used readability tests, which are principally
employed for assessment of the difficulty to understand a reading passage
written in English. The Flesch Reading Ease score of a passage relies solely
on three statistics, namely the total numbers of sentences, words and
syllables, of the passage.

Sample Output

26.09

Source


#include <stdio.h>
#include<string.h>
#include<math.h>

char test[1005];
double wor, sen, syl;

bool check2(char x)
{
	if (x == 'a' || x == 'e' || x == 'o' || x == 'u' || x == 'y' || x == 'i' || x == 'A' || x == 'E' || x == 'I' || x == 'O' || x == 'U' || x == 'Y')
	{
		return true;
	}
	else
	{
		return false;
	}
}

int check(char *x)
{
	int len = strlen(x);
	int i, res;
	while (!((x[len - 1] >= 'a'&&x[len - 1] <= 'z') || (x[len - 1] >= 'A'&&x[len - 1] <= 'Z')))
	{
		len--;
	}

	res = 0;
	if (len <= 3)
	{
		return 1;
	}
	if (x[len - 2] == 'e'&&x[len - 1] == 's')
	{
		len = len - 2;
	}
	else if (x[len - 2] == 'e'&&x[len - 1] == 'd')
	{
		len = len - 2;
	}
	else if (x[len - 1] == 'e')
	{
		if (x[len - 2] != 'l')
		{
			len = len - 1;
		}
	}
	if (check2(x[0]))
	{
		res++;
	}
	for (i = 1; i < len; i++)
	{
		if (check2(x[i]) && !check2(x[i - 1]))
		{
			res++;
		}
	}
	return res;
}

int main()
{
	wor = 0;//单词个数
	sen = 0;//句子个数
	syl = 0;//音节个数

	int len;
	char temp;
	double res;
	while (scanf("%s", test) != EOF)
	{
		wor++;
		len = strlen(test);

		temp = test[len - 1];
		if (temp == '.' || temp == '?' || temp == ':' || temp == ';' || temp == '!')
		{
			sen++;
		}
		syl += check(test);
	}

	res = 206.835 - 1.015*(wor / sen) - 84.6*(syl / wor);
	printf("%.2f\n", res);

	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值