POJ 2528 Mayor's posters 线段树+离散化

这题的题意是在一段线段上贴海报,给了贴的顺序和海报覆盖的区域,问最后能看见的海报个数。首先后面贴的海报能覆盖前面的海报,所以我们从后面开始贴,如果贴的区域之前已经被覆盖了就说明这个海报不可能被看见,否则数量+1。

由于线段长度范围很大,但是海报的数量只有10000,所以应该对数据进行离散化。



The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 
Input
The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l  i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l  i<= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l  i, l  i+1 ,... , ri.
Output
For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 
Sample Input
1
5
1 4
2 6
8 10
3 4
7 10
Sample Output
4


#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
#define lson tree[id<<1]
#define rson tree[id<<1|1]
#define e tree[id]
#define N 10000+5
int L[N],R[N];
int X[N<<2];
bool flag;
struct Tree
{
    int le,ri;
    bool cover;
}tree[N<<4];
void build(int id,int le,int ri)
{
    e.le=le;
    e.ri=ri;
    e.cover=false;
    if(le==ri)
        return ;
    int mid=(le+ri)>>1;
    build(id<<1,le,mid);
    build(id<<1|1,mid+1,ri);
}
void pushdown(int id)
{
    if(e.cover)
    {
        lson.cover=rson.cover=true;
    }
}
void pushup(int id)
{
    if(lson.cover&&rson.cover)
        e.cover=true;
    else
        e.cover=false;
}
void update(int ql,int qr,int id)
{
    int le=e.le,ri=e.ri;
    if(le==ql&&ri==qr)
    {
        if(!e.cover)
        {
            flag=true;
            e.cover=true;
        }
        return ;
    }
    pushdown(id);
    int mid=(le+ri)>>1;
    if(qr<=mid)
        update(ql,qr,id<<1);
    else
    {
        if(ql>mid)
            update(ql,qr,id<<1|1);
        else
        {
            update(ql,mid,id<<1);
            update(mid+1,qr,id<<1|1);
        }
    }
    pushup(id);
}
int bin(int key,int n)
{
    int ul=1,ur=n;
    while(ul<=ur)
    {
        int m=(ul+ur)>>1;
        if(X[m]==key)
            return m;
        if(X[m]>key)
            ur=m-1;
        else
            ul=m+1;
    }
}
int main()
{
    int T,n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        int cnt=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&L[i],&R[i]);
            X[++cnt]=L[i];
            X[++cnt]=R[i];
        }
        sort(X+1,X+1+cnt);
        int k=unique(X+1,X+1+cnt)-X-1;
        cnt=k;
        for(int i=k;i>1;i--)
        {
            if(X[i]!=X[i-1]+1)
                X[++cnt]=X[i-1]+1;
        }
        //cout<<cnt<<endl;
        sort(X+1,X+1+cnt);
        build(1,1,cnt);
        int ans=0;
        for(int i=n;i>=1;i--)
        {
            flag=false;
            int ql=bin(L[i],cnt),qr=bin(R[i],cnt);
            update(ql,qr,1);
            if(flag)
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值