POJ 3281 Dining 网络流



             这题的关键是如何建边。

             图的顶点是食物所对应的匹配中的食物和牛,饮料对应的匹配中的饮料和牛,源点s,汇点t

             食物匹配和饮料匹配中相同的牛之间连一条边,这样可以确保一头牛不会分配多组食物和饮料。

             边:s->食物->牛->牛->饮料->t


Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input
Line 1: Three space-separated integers:  NF, and  D 
Lines 2..  N+1: Each line  i starts with a two integers  Fi and  Di, the number of dishes that cow  i likes and the number of drinks that cow  i likes. The next  Fiintegers denote the dishes that cow  i will eat, and the  Di integers following that denote the drinks that cow  i will drink.
Output
Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes
Sample Input
4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3
Sample Output
3
Hint
One way to satisfy three cows is: 
Cow 1: no meal 
Cow 2: Food #2, Drink #2 
Cow 3: Food #1, Drink #1 
Cow 4: Food #3, Drink #3 
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <vector>
using namespace std;
int N,F,D;
const int maxn=1000;
#define INF 1000000000
bool likeF[maxn][maxn];
bool likeD[maxn][maxn];
struct edge
{
    int to,cap,rev;
    edge(int t,int c,int r)
    {
        to=t;
        cap=c;
        rev=r;
    }
};
vector<edge> G[maxn];
bool used[maxn];
void add_edge(int from,int to,int cap)
{
    edge a(to,cap,G[to].size());
    edge b(from,0,G[from].size());
    G[from].push_back(a);
    G[to].push_back(b);
}
int dfs(int v,int t,int f)
{
    if(v==t)
        return f;
    used[v]=true;
    for(int i=0;i<G[v].size();i++)
    {
        edge &e=G[v][i];
        if(!used[e.to]&&e.cap>0)
        {
            int d=dfs(e.to,t,min(f,e.cap));
            if(d>0)
            {
                e.cap-=d;
                G[e.to][e.rev].cap+=d;
                return d;
            }
        }
    }
    return 0;
}
int max_flow(int s,int t)
{
    int flow=0;
    for(;;)
    {
        memset(used,0,sizeof(used));
        int f=dfs(s,t,INF);
        if(f==0)
            return flow;
        flow+=f;
    }
}
void solve()
{
    int s=N*2+F+D,t=s+1;
    for(int i=0;i<F;i++)
        add_edge(s,N*2+i,1);
    for(int i=0;i<D;i++)
        add_edge(N*2+F+i,t,1);
    for(int i=0;i<N;i++)
    {
        add_edge(i,N+i,1);
        for(int j=0;j<F;j++)
        {
            if(likeF[i][j])
                add_edge(N*2+j,i,1);
        }
        for(int j=0;j<D;j++)
        {
            if(likeD[i][j])
                add_edge(N+i,N*2+F+j,1);
        }
    }
    printf("%d\n",max_flow(s,t));
}
int main()
{
    while(scanf("%d%d%d",&N,&F,&D)!=EOF)
    {
        memset(likeF,false,sizeof(likeF));
        memset(likeD,false,sizeof(likeD));
        for(int i=0;i<N;i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            int x;
            for(int j=1;j<=a;j++)
            {
                scanf("%d",&x);
                x--;
                likeF[i][x]=true;
            }
            for(int j=1;j<=b;j++)
            {
                scanf("%d",&x);
                x--;
                likeD[i][x]=true;
            }
        }
        solve();
    }
    return 0;
}















评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值