Co-prime

http://acm.hdu.edu.cn/showproblem.php?pid=4135

Co-prime

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2481    Accepted Submission(s): 933


Problem Description
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
 

Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10 15) and (1 <=N <= 10 9).
 

Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
 

Sample Input
  
  
2 1 10 2 3 15 5
 

Sample Output
  
  
Case #1: 5 Case #2: 10
Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.
 

Source
 

初次接触容斥

#include <cstdio>
#include <vector>
using namespace std;
vector<int>fac;
void get_fac(__int64 n){
    for(__int64 i=2;i*i<=n;i++){
        if(n%i==0){
            fac.push_back((int)i);
            while(n%i==0)n/=i;
        }
    }
    if(n!=1)fac.push_back((int)n);
}
__int64 solve(__int64 a){
    //cnt表示有几个集合,lcm是集合的元素个数
    __int64 sum=0;
    int cnt=fac.size();
    for(int num=1;num<(1<<cnt);num++){//cnt个集合,容斥定理中就有2的cnt次方-1项,num是二进制压缩//3为11,代表A1交A2
        __int64 mult=1,ones=0;
        for(int i=0;i<cnt;i++){//i表示第几个集合,例如i=2,表示为100,表示为第三个集合
            if(num&(1<<i)){//当i为0的时候,判断第一个集合是否进行交集操作
            ones++;//当ones为偶数的时候,那么就是减,当noes为奇数的时候为加
            mult*=fac[i];
            }
        }
    if(ones%2) sum+=a/mult;
    else sum-=a/mult;
    }
    return a-sum;
}
int main()
{
    //freopen("F://in.txt","r",stdin);
    int t;
    scanf("%d",&t);
    for(int Case=1;Case<=t;Case++){
        __int64 a,b,n;
        fac.clear();
        scanf("%I64d%I64d%I64d",&a,&b,&n);
        get_fac(n);
        __int64 ans=solve(b)-solve(a-1);
        printf("Case #%d: %I64d\n",Case,ans);
    }
    return 0;
}
AC之路上,我选择坚持~~~

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值