Minimum Inversion Number

http://acm.hdu.edu.cn/showproblem.php?pid=1394

树状数组求逆序数,逆序数个数为出现过的比当前的数字大的元素的个数,就是该数逆序数的个数,这里对于一个数a[i],所有已出现的数都是1,那么getsum(n),就是求所有已经出现过的数的个数,也可以是i,getsum(a[i])就是求所有比a[i]小的元素的个数,那么逆序数的个数就是i-getsum(a[i]);

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15131    Accepted Submission(s): 9241


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

Author
CHEN, Gaoli
 

Source
 
#include <cstdio>
#include <cstring>
int a[5010];
int c[5010];//树状数组存储比i大的元素的个数
int n;
int bit(int t){
    return t&(-t);
}
void update(int pos,int num){
    while(pos<=n){
        c[pos]+=num;
        pos+=bit(pos);
    }
}
int getsum(int pos){
    int ans=0;
    while(pos>0){
        ans+=c[pos];
        pos-=bit(pos);
    }
    return ans;
}
int main(){
    while(scanf("%d",&n)!=EOF){
        memset(c,0,sizeof(c));
        int minnum=0;
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
            a[i]++;
            minnum+=getsum(n)-getsum(a[i]);
            update(a[i],1);//使用树状数组你可以看成修改原数组的值就用update,求和就用getsum函数;
        }
        int m=minnum;
        for(int i=0;i<n;i++){
            m+=n-2*a[i]+1;
            if(m<minnum)minnum=m;
        }
        printf("%d\n",minnum);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值