HDU--杭电--Minimum Inversion Number--线段树--基础

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8314    Accepted Submission(s): 5106
Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj. For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following: a1, a2, ..., an-1, an (where m = 0 - the initial seqence) a2, a3, ..., an, a1 (where m = 1) a3, a4, ..., an, a1, a2 (where m = 2) ... an, a1, a2, ..., an-1 (where m = n-1) You are asked to write a program to find the minimum inversion number out of the above sequences.
 
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 
Output
For each case, output the minimum inversion number on a single line.
 
Sample Input
   
   
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
   
   
16

 
题意就是给你一个排列,求出逆序数,然后根据每次把第一个放最后的方式得到新排列再求逆序数,最后输出最小的

线段树的应用就是求逆序数的时候,记录每个数字是否出现以及个数

#include <iostream>
#include <cstdio>
using namespace std;
struct node
{
    int l,r,n;
}tree[1000000];
void setit(int l,int r,int step)
{
    tree[step].l=l;
    tree[step].r=r;
    tree[step].n=0;
    if(l==r)return;
    setit(l,(l+r)/2,2*step);
    setit((l+r)/2+1,r,2*step+1);
}
void insert(int l,int r,int k,int step)	//插入一个k
{
    tree[step].n++;
    if(l==r)return;
    int mid=(l+r)/2;
    if(mid>=k)insert(l,mid,k,2*step);
    else insert(mid+1,r,k,2*step+1);
}
int find(int l,int r,int k,int step)	//查找并返回所有小于k的数的个数
{
    int mid=(l+r)/2;
    if(k<0||k==r)return tree[step].n;
    if(mid<k)return find(l,mid,-1,2*step)+find(mid+1,r,k,2*step+1);
    return find(l,mid,k,2*step);
}
int main (void)
{
    int s[11111],i,j,k,l,n,sum,Min;
    while(scanf("%d",&n)!=EOF)
    {
        setit(0,n-1,1);
        for(i=sum=0;i<n;i++)
        scanf("%d",&s[i]),sum+=i-find(0,n-1,s[i],1),insert(0,n-1,s[i],1);
        Min=sum;
        for(i=1;i<n;i++)
        {
            sum+=n-1-2*s[i-1];
            if(sum<Min)Min=sum;
        }
        printf("%d\n",Min);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值