Packets

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 

1

题目大意:只有6*6的箱子,有1*1 2*2 3*3 4*4 5*5 6*6的物品,问最少需要多少箱子可以装下物品

思路:对于6*6 5*5 的都需要独占一个,因为放不下2*2的了,3*3的可以放四个,主要就是解决2*2的,剩下的用1*1的补齐就行了

对于2*2的,放1个3*3 的 则可以放5个2*2

放2个 3*3 则3个 2*2

放3个 3*3 则1个2*2

 

#include <iostream>
using namespace std;
int main(){
    int i,j,n,sum=1;
    int a[7],v1,v2,s;
    int a3[4]={0,5,3,1};
    while(sum)
    {
        sum=0;
        n=0;
        for(i=1;i<=6;i++)
        {
            cin>>a[i];
            sum+=a[i];
        }
        if(sum==0)break;
        n=a[6]+a[5]+a[4]+(a[3]+3)/4;//先把大的挑出来,看至少需要几个箱子
        j=a[3]%4;//解决3*3的余下的空间
        v2=a[4]*5+a3[j];//放下大的之后给2*2的空间
        if(a[2]>v2)//剩余的2*2箱子重新进另一新箱子
            n=n+(a[2]-v2+8)/9;
        s=0;
        for(i=2; i<=6; i++)
        {
            s+=a[i]*i*i;
        }
        v1=n*36-s;
        if(a[1]>v1)//最后解决给1*1剩下的位置
            n+=(a[1]-v1+35)/36;
        cout<<n<<endl;
    }
    return 0;
} <iostream>
using namespace std;
int main(){
    int i,j,n,sum=1;
    int a[7],v1,v2,s;
    int a3[4]={0,5,3,1};
    while(sum)
    {
        sum=0;
        n=0;
        for(i=1;i<=6;i++)
        {
            cin>>a[i];
            sum+=a[i];
        }
        if(sum==0)break;
        n=a[6]+a[5]+a[4]+(a[3]+3)/4;//先把大的挑出来,看至少需要几个箱子
        j=a[3]%4;//解决3*3的余下的空间
        v2=a[4]*5+a3[j];//放下大的之后给2*2的空间
        if(a[2]>v2)//剩余的2*2箱子重新进另一新箱子
            n=n+(a[2]-v2+8)/9;
        s=0;
        for(i=2; i<=6; i++)
        {
            s+=a[i]*i*i;
        }
        v1=n*36-s;
        if(a[1]>v1)//最后解决给1*1剩下的位置
            n+=(a[1]-v1+35)/36;
        cout<<n<<endl;
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值