Last non-zero Digit in N!

Last non-zero Digit in N!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1138 Accepted Submission(s): 463
 
Problem Description
The expression N!, read as "N factorial," denotes the product of the first N positive integers, where N is nonnegative. So, for example,  
N N!  
0 1  
1 1  
2 2  
3 6  
4 24  
5 120  
10 3628800  

For this problem, you are to write a program that can compute the last non-zero digit of the factorial for N. For example, if your program is asked to compute the last nonzero digit of 5!, your program should produce "2" because 5! = 120, and 2 is the last nonzero digit of 120.  
 
Input
Input to the program is a series of nonnegative integers, each on its own line with no other letters, digits or spaces. For each integer N, you should read the value and compute the last nonzero digit of N!.
 
Output
For each integer input, the program should print exactly one line of output containing the single last non-zero digit of N!.
 
Sample Input
1 
2 
26 
125 
3125 
9999
 
Sample Output
1
2
4
8
2
8
题目大意:给定一个数n,求n!的最后一位不为0的数
猛地一看,直接暴力,碰到0,就除以10,直到不为0为止,取余。。。结果TLE
#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
    int n;
    while(scanf("%d",&n))
    {
        int sum=1;
        for(int i=1;i<=n;i++)
        {
            sum=sum*i;
            while(sum%10==0)sum=sum/10;
            sum=sum%100000;
        }
        while(sum%10==0)sum=sum/10;
        sum=sum%10;
        printf("%d\n",sum);
    }
    return 0;
}
下面是AC代码,这是某位大佬代码
#include<string.h>
#include <iostream>
#include<stdio.h>
using namespace std;
int mod[20]={1,1,2,6,4,2,2,4,2,8,4,4,8,4,6,8,8,6,8,2};
// 直接计算出其循环节为20这里将0-19的列表于上,当N<5时直接输出,其余需要递归N/5因为这个表是删除了所有的5的倍数的 
int main( ){
    char str[1024];
    int num[1024];
    while( scanf( "%s",str )==1 )
    {
          int len=strlen(str),ans=1;
          for( int i=0 ;i<len;i++)
               num[i]=str[len-i-1]-'0';
          while(len)
          {
             len-=!num[len-1];
             ans=ans*mod[num[1]%2*10+num[0]]%10;
             for( int i=len-1,c=0;i>=0;i--){
                    c=c*10+num[i];
                    num[i]=c/5;
                    c%=5;//余数 
                    }    
          }    
          printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值