Monkey and Banana

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1041 Accepted Submission(s): 635
 
Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 
Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
 
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342
题目:给你一些立方体的长宽高,每个长方体都有n个,按照严格的下面的每一条边都比上面的大,不能等于,就是长和宽都需要大才行,求一个最大高度。
这题wa成,错了n次,之前有做过这个题,我还一直以为我是输出错误,到最后直接到网上贴了个代码,
感觉跟我的没什么不同,具体思路都是先按照长和宽排序,因为有三条边,所以有三种情况,都举出来,然后是动态规划,每次先以当前
高度为dp最优解,然后循环找全局最优解。下面是我出错的代码
#include <iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
struct box
{
    int l;
    int w;
    int h;
    int dp;//该箱子在最下面时的最大高度 
}b[201];
bool cmp(box a,box b)//先按x后按y
{
    if(a.l>b.l) return 1;
    else if(a.l==b.l&&a.w>b.w)  return 1;
    else return 0;
    /*if(a.l>b.l&&a.w>b.w)return 1;
    else return 0;*/
}
int max(int a,int b)        
{
    if(a>b)return a;
    else return b;
}
int main()
{
    int n,i,j,k;
    int l,w,h;
    int cc=1;
    box temp;//中间变量
    while(cin>>n)
    {
        if(n==0)break;
        memset(b,0,sizeof(b));
        int maxx=0;
        k=0;
        for(i=0;i<n;i++)
        {
            cin>>l>>w>>h;//三中情况,每条边都当一次长宽高
            temp.l=l;
            temp.w=w;
            temp.h=h;
            b[k++]=temp;
            temp.l=w;
            temp.w=h;
            temp.h=l;
            b[k++]=temp;
            temp.l=h;
            temp.w=w;
            temp.h=l;
            b[k++]=temp;
        }
        sort(b,b+n*3,cmp);
        b[0].dp=b[0].h;
        for(i=1;i<3*n;i++)
        {
                b[i].dp=b[i].h;
                for(j=0;j<i;j++)
                {
                    if( (b[i].w<b[j].w&&b[i].l<b[j].l)||(b[i].w<b[j].l&& b[i].l<b[j].w) )//满足题目给出的条件
//if(b[i].w<b[j].w&&b[i].l<b[i].l)
                        b[i].dp=max(b[i].dp,b[j].dp+b[i].h);
                }
                if(b[i].dp>maxx)
                    maxx=b[i].dp;
        }
        //cout<<"Case "<<cc<<": maximum height = "<<maxx<<endl;
        printf("Case %d: maximum height = %d\n",cc,maxx);
        cc++;
    }
    return 0;
}
时隔一个月  终于A了这道题 在原来的思路的基础上,把长方体的一条边固定,变换另外两个,每次出现6组长方体,排序,
转化为一个最大子序列问题,就是加了限制,
//7.19
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
int maxx (int a,int b)
{
    if(a>b)return a;
    else return b;
    }
struct box
{
    int l,w,h;
    //int tower;
    }temp;
bool cmp(box a,box b)
{
    if(a.l>b.l) return 1;
    else if(a.l==b.l&&a.w>b.w)  return 1;
    else return 0;
    }
int main()
{
    box a[300];
    int ans[300];
    int i,j,max,n;
    int l,w,h;
    int k=0;
    int num=1;
    while(cin>>n)
    {
        max=0;
        k=0;
        memset(a,0,sizeof(a));
        if(n==0)break;
        for(i=0;i<n;i++)
        {
            scanf("%d %d %d",&l,&w,&h);
            temp.l=l;
            temp.w=w;
            temp.h=h;
            a[k++]=temp;
            temp.l=l;
            temp.w=h;
            temp.h=w;
            a[k++]=temp;
            temp.l=w;
            temp.w=h;
            temp.h=l;
            a[k++]=temp;
            temp.l=w;
            temp.w=l;
            temp.h=h;
            a[k++]=temp;
            temp.l=h;
            temp.w=l;
            temp.h=w;
            a[k++]=temp;
            temp.l=h;
            temp.w=w;
            temp.h=l;
            a[k++]=temp;
        }
        sort(a,a+k+1,cmp);
        ans[0]=a[0].h;
        for(i=0;i<k;i++)//for(i=1;i<3*n;i++)
        {
            //a[i].tower=a[i].h;
            //cout<<a[i].l<<" "<<a[i].w<<" "<<a[i].h<<endl;
            ans[i]=a[i].h;
            int maxh=0;
            for(j=i-1;j>=0;j--)
            {
                if(a[i].l<a[j].l&&a[i].w<a[j].w)
                    //a[i].tower=maxx(a[i].tower,a[j].tower+a[i].h);
                    if(maxh<ans[j])
                    maxh=ans[j];
            }
            ans[i]+=maxh;
            if(ans[i]>max)
                max=ans[i];
        }
        cout<<"Case "<<num<<": maximum height = "<<max<<endl;
        num++;
        }
    return 0;
    }

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
#include <stdio.h> int main(){ void gobox(int a,int b); void getbox(); void findbanana(int a,int b); void getbanana(); int monkey,banana,box; printf("请依次输入猴子,香蕉,箱子 的位置\n"); printf("猴子的位置:"); scanf("%d",&monkey); printf("香蕉的位置:"); scanf("%d",&banana); printf("箱子的位置:"); scanf("%d",&box); printf("-----------------------------------\n"); if(monkey!=box){ printf("猴子够不到香蕉,要先去搬箱子:"); gobox(monkey,box); getbox(); if(box!=banana){ printf("猴子需要搬着箱子去找到香蕉:"); findbanana(banana,box); getbanana(); }else{ printf("香蕉就在箱子的上面\n"); getbanana(); } }else{ printf("箱子就在猴子旁边,猴子拿到了箱子"); getbox(); if(box!=banana){ printf("猴子需要搬着箱子去找到香蕉:"); findbanana(banana,box); getbanana(); }else{ printf("香蕉就在箱子的上面\n"); getbanana(); } } } void gobox(int a,int b){ int flag; flag = b - a; if(flag>0){ printf("Run(monkey,box)\n"); printf("猴子需要向右移动%d步拿到箱子\n",flag); }else{ printf("Run(monkey,box)\n"); printf("猴子需要向左移动%d步拿到箱子\n",flag); } } void findbanana(int a,int b){ int flag; flag=b-a; if(flag>0){ printf("Run(monkey,banana)\n"); printf("猴子需要向左搬着箱子移动%d步找到香蕉\n",flag); }else{ printf("Run(monkey,banana)\n"); printf("猴子需要向右搬着箱子移动%d步找到香蕉\n",flag); } } void getbox(){ printf("猴子拿到了箱子:"); printf("Getbox(monkey,box)\n"); } void getbanana(){ printf("猴子踩在箱子上拿到了香蕉:"); printf("Getbanana(monkey,banana)\n"); }请输出主要数据定义和主要功能模块设计
05-25

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值