Sudoku

Sudoku

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 107   Accepted Submission(s) : 34
Special Judge
Problem Description
Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task. 
 

Input
The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.
 

Output
For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.
 

Sample Input
  
  
1 103000509 002109400 000704000 300502006 060000050 700803004 000401000 009205800 804000107
 

Sample Output
  
  
143628579 572139468 986754231 391542786 468917352 725863914 237481695 619275843 854396127
题意:很有意思 数独
思路:之前做过数独杀手的一个,直接在源代码的基础上修改标识符和输入输出的差异 以为差不多 
写死机了两次 结束都结束不掉 一直tle
找了个比较好理解的题解,对于填数据,都是采用的暴力
[i][j] 各数组分别代表当前行有没有j,当前列有么有j,每个小九宫格有没有j 这样很好理解
还有一种解法就是每行每列每个小九宫格单独判断有没有将要填上的数据,判断当前vis,没试过就一直试,
两种方式最关键的都是恢复
  • Source Code
    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    using namespace std;
    int map[12][12];
    int judgex[12][12];
    int judgey[12][12];
    int judgenine[12][12];
    int dfs(int x,int y)
    {
        int i,j,num;
        if(x==10)
            return 1;
        int flag=0;
        if(map[x][y]!=0)
        {
            if(y==9)
                 flag=dfs(x+1,1);
             else
                 flag=dfs(x,y+1);
             if(flag)
                 return 1;
             else
                 return 0;
         }
         else{
             num=3*((x-1)/3)+(y-1)/3+1;
             for(i=1;i<=9;i++)
                 if(!judgex[x][i]&&!judgey[y][i]&&!judgenine[num][i])
                 {
                     map[x][y]=i;
                     judgex[x][i]=1;
                     judgey[y][i]=1;
                     judgenine[num][i]=1;
                     if(y==9)
                         flag=dfs(x+1,1);
                     else
                         flag=dfs(x,y+1);
                     if(flag)
                         return 1;
                     else {
                         judgex[x][i]=0;
                         judgey[y][i]=0;
                         judgenine[num][i]=0;
                         map[x][y]=0;
                     }
                 }
         }
         return 0;
     }
     int main()
     {
         int t,i,j,num,ans;
         char a;
         cin>>t;
         while(t--)
         {
             memset(map,0,sizeof(map));
             memset(judgex,0,sizeof(judgex));
             memset(judgey,0,sizeof(judgey));
             memset(judgenine,0,sizeof(judgenine));
             for(i=1;i<=9;i++)
             {
                 for(j=1;j<=9;j++)
                 {
                     cin>>a;
                     map[i][j]=a-'0';
                     if(map[i][j])
                     {
                        num=((i-1)/3)*3+(j-1)/3+1;
                        judgex[i][map[i][j]]=1;
                        judgey[j][map[i][j]]=1;
                        judgenine[num][map[i][j]]=1;
                        }
                    }
                }
             dfs(1,1);
             for(i=1;i<=9;i++)
             {
                 for(j=1;j<=9;j++)
                     cout<<map[i][j];
                 cout<<endl;
                }
            }
         return 0;
     }

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值