Expanding Rods

Expanding Rods

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 123   Accepted Submission(s) : 43
Problem Description
When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion. 
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment. 

Your task is to compute the distance by which the center of the rod is displaced. 
 

Input
The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.
 

Output
For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision. <br>
 

Sample Input
  
  
1000 100 0.0001 15000 10 0.00006 10 0 0.001 -1 -1 -1
 

Sample Output
  
  
61.329 225.020

0.000

题意:加热后中间的棒子会变形,给出变形前长度l,温度,形变率,变形后长度计算公式已给出  

问你垂直平分线的顶点距离原来的水平线多远

思路:思路:

通过二分枚举高度,进而确定半径,弧长,与新长度比较判别

  • Source Code
    #include<iostream>
    #include<stdio.h>
    #include<cmath>
    #include<iomanip>
    using namespace std;
    int main()
    {
        double l,newl,c,t;
        while(cin>>l>>t>>c)
        {
            if(l==-1.0&&t==-1.0&&c==-1.0)
                break;
            newl=(1+t*c)*l;
            //cout<<newl<<endl;
            double mid,low=0,high=l/2;
            //cout<<high<<endl;
            double r,templ;
            while(high-low>1e-6)
            {
                mid=(low+high)/2;
                r=(l*l+4*mid*mid)/(8*mid);
                templ=2*r*asin(l/(2*r));
                if(templ<newl)
                    low=mid;
                else
                    high=mid;
                }
            cout<<fixed<<setprecision(3)<<low<<endl;
            }
        return 0;
    }

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值