poj 3169(最短路 差分约束)

Layout

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16053 Accepted: 7712

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

 

意:有n头牛,他们按顺序排成了一排,有些牛关系比较好,他们的距离不能超过某个距离,还有些牛关系不好,他们之间的距离不能小于某个距离,可能会有多头牛挤在同一位置上,问1号牛和n号牛之间的最大距离是多少,如果不存在满足条件的排列则输出-1,如果距离无限大则输出-2.

分析:令d[i]表示第i头牛的位置,因为牛按顺序排列,则有d[i] <= d[i+1],关系好的牛有d[a] +D >= d[b], 关系不好的牛有d[a] + d <= d[b],把不等式标准化之后直接跑最短路即可。

如果无限大则输出-2,不存在排列输出-1.

#include<iostream>
#include<cmath>
#include<cstdio>
#include<queue>
#include<cstdlib>
#include<cstring>

using namespace std;
const int N=1e4+10;
const int inf=0x3f3f3f3f;
struct node
{
	int to,dis,next;
}edge[N<<2];
int head[N],cnt;
void addedge(int from,int to,int dis)
{
	edge[cnt].to=to;
	edge[cnt].dis=dis;
	edge[cnt].next=head[from];
	head[from]=cnt++;
}

int dis[N];
bool vis[N];
int num[N];
int spfa(int n)
{
	memset(num,0,sizeof(num));
	memset(dis,inf,sizeof(dis));
	memset(vis,false,sizeof(vis));
	dis[1]=0;
	vis[1]=true;
	queue<int>Q;
	Q.push(1);
	while(!Q.empty()){
		int u=Q.front();
		Q.pop();
		vis[u]=false;
		for(int i=head[u];i!=-1;i=edge[i].next){
			int to=edge[i].to;
			if(dis[to]>dis[u]+edge[i].dis){
				dis[to]=dis[u]+edge[i].dis;
				if(!vis[to]){
					vis[to]=true;
					Q.push(to);
					if(++num[to]>n) return -1;
				}
			}
		}
	} 
	return dis[n]==inf?-2:dis[n];
} 
int main()
{
	memset(head,-1,sizeof(head));
	int n,ml,md;
	scanf("%d %d %d",&n,&ml,&md);
	for(int i=0;i<ml;i++){
		int a,b,c;
		scanf("%d %d %d",&a,&b,&c);
		addedge(a,b,c); 
	}
	for(int i=0;i<md;i++){
		int a,b,c;
		scanf("%d %d %d",&a,&b,&c);
		addedge(b,a,-c);
	}
	printf("%d\n",spfa(n));
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值