【hdu1242】Rescue——bfs+小根堆

题目:

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24209    Accepted Submission(s): 8538


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
  
  
13
 

Author
CHEN, Xue
 

Source

描述:给定多个起点和一个终点的map,求起点到终点的最短路径,其中上下左右分别消耗一单位时间,#表示不能走,x要额外多花费一单位时间

题解:将终点当作起点,起点作为终点进行bfs。要注意的是由于x的存在使队列中的不是按照到起点的步长进行排序,导致得到的结果不一定是最短的,所以用优先队列来维护这一性质。这里学习了优先队列表示小根堆的另一种写法。

代码:

#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
const int maxn = 205;
char map[maxn][maxn];
int dx[] = { 0,0,-1,1 };
int dy[] = { -1,1,0,0 };
struct point
{
	int x;
	int y;
	int dis;
	friend bool operator< (point a,point b)
	{
		return a.dis > b.dis;
	}
};
int main()
{
	int n, m;
	point p;
	while (scanf("%d%d", &n, &m) != EOF)
	{
		getchar();
		for (int i = 0; i < n; i++)
		{
			for (int j = 0; j < m; j++)
			{
				scanf("%c", &map[i][j]);
				if (map[i][j] == 'a')
				{
					p.x = i;
					p.y = j;
				}
			}
			getchar();
		}
		priority_queue<point> que;
		p.dis = 0;
		que.push(p);
		map[p.x][p.y] = '#';
		int ans = 0;
		while (!que.empty())
		{
			point p1 = que.top();
			que.pop();
			for (int i = 0; i < 4; i++)
			{
				point temp;
				temp.x = p1.x + dx[i];
				temp.y = p1.y + dy[i];
				if (temp.x < 0 || temp.x >= n || temp.y < 0 || temp.y >= m || map[temp.x][temp.y] == '#')
					continue;
				temp.dis = p1.dis + 1;
				if (map[temp.x][temp.y] == 'x')
					temp.dis++;
				if (map[temp.x][temp.y] == 'r')
					ans = temp.dis;
				if (ans != 0)break;
				que.push(temp);
				map[temp.x][temp.y] = '#';
			}
			if (ans != 0)break;
		}
		if (ans == 0)
			printf("Poor ANGEL has to stay in the prison all his life.\n");
		else
			printf("%d\n", ans);
	}

	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值