D - Silver Cow Party

D - Silver Cow Party

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1…N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way. Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2…M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output
10

题目大意:
有一群牛(共n只)聚会,到某一只牛(x)家里面去,已知有m条路,且每一条路为单向的.
求出在所有牛中走路最长的那头牛所走的路.
知识点:

Dijstra算法用于计算源点到其余个点的距离

而此题目中 要求

(1)x号点到其余所有点的距离(可以用Dijstra 算法)

(2)其余所有点到x号点的距离(不能直接求得,需要转换思维)

   最好的办法就是求出转置矩阵,再对转置矩阵求Dijstra(),便的出所有号点到x号点的距离

代码:

#include<stdio.h>
#include<math.h>
#include<string.h>
#define Max 0x3fffffff
#define max(a,b) (a<b?b:a)
int n,m,x;
int map[1100][1100],dis[1100],visit[1100],way[1100];
void Dijkstra(int x)
{
    int min,k;
    for(int i=1; i<=n; i++)//visit标记查询过的点
        visit[i]=0;
    visit[x]=1;

    for(int i=1; i<=n; i++)//一定不要把顺序搞错,这时的map[i][j]与map[j][i]不一定一样。
        dis[i]=map[x][i];

    for(int i=2; i<=n; i++)
    {
        min=Max;
        for(int j=1; j<=n; j++)
        {
            if(!visit[j]&&dis[j]<min)
            {
                min=dis[j];
                k=j;
            }
        }
        visit[k]=1;
        for(int i=1; i<=n; i++)
        {
            if(!visit[i]&&dis[i]>dis[k]+map[k][i])
                dis[i]=dis[k]+map[k][i];
        }
    }
}
int main()
{
    while(~scanf("%d%d%d",&n,&m,&x))
    {
        int ans=0;
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
            {
                if(i==j)
                    map[i][j]=0;
                else
                    map[i][j]=Max;
            }

        int a,b,t;
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d%d",&a,&b,&t);
            if(map[a][b]>t)
                map[a][b]=t;
        }

        Dijkstra(x);

        for(int i=1; i<=n; i++)
            way[i]=dis[i];

        for(int i=1; i<=n; i++)//转换矩阵
        {
            for(int j=i+1; j<=n; j++)
            {
                int tmp;
                tmp=map[j][i];
                map[j][i]=map[i][j];
                map[i][j]=tmp;
            }
        }

        Dijkstra(x);//第二次使用Dijkstra算法来找出从x农场到家的最短路径

        for(int i=1; i<=n; i++)
        {
            ans=max(ans,way[i]+dis[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值