A - Wireless Network

A - Wireless Network

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.
In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:

  1. “O p” (1 <= p <= N), which means repairing computer p.
  2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.
    The input will not exceed 300000 lines.

Output

For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

并查集,提高题。
  算是并查集的应用,拐了点弯。

题意:
  有一个计算机网络的所有线路都坏了,网络中有n台计算机,现在你可以做两种操作,修理(O)和检测两台计算机是否连通(S),只有修理好的计算机才能连通。连通有个规则,两台计算机的距离不能超过给定的最大距离D(一开始会给你n台计算机的坐标)。检测的时候输出两台计算机是否能连通。

思路:
  每次修理好一台计算机的时候就遍历一下所有修好的计算机,看距离是否<=D,如果符合说明可以连通,将两台计算机所在集合合并。
  每次检查的时候判断一下这两台计算机是否在同一集合中即可。

注意:
  1、坐标之后给出的计算机编号都是n+1的。例如O 3,他实际上修理的是编号为2的计算机,因为计算机是从0开始编号的。
  2、比较距离的时候注意要用浮点数比较,否则会WA。
  3、“FAIL"不要写成"FALL”。
  4、字符串输入的时候注意处理好回车,空格等情况。
  5、注意N的范围(1 <= N <= 1001),最大是1001,不是1000。是个小坑,数组开小了可能会错哦。

另外测试了一下使用路径压缩,和不使用路径压缩的效率。使用是1079MS(C++),不使用是2032MS(C++),时间缩短了一倍。
  另外C++和G++提交时间相差也很大。同样的代码G++就变成了3063MS(G++)。
 
 代码:

#include <iostream>
#include <stdio.h>
#include <cmath>
using namespace std;

#define MAXN 1010

int dx[MAXN],dy[MAXN];    //坐标
int par[MAXN];    //par[x]表示x的父节点
int repair[MAXN] = {0};
int n;

void initialise()    //初始化
{
    int i;
    for(i=0; i<=n; i++)
        par[i] = i;
}

int find_root(int x)    //查询x的根节点并路径压缩
{
    if(par[x]!=x)
        par[x] = find_root(par[x]);
    return par[x];
}

void union_vertices(int x,int y)    //合并x和y所在集合
{
    par[find_root(x)] = find_root(y);
}

int Abs(int n)
{
    return n>0?n:-n;
}

double Dis(int a,int b)
{
    return sqrt( double(dx[a]-dx[b])*(dx[a]-dx[b]) + (dy[a]-dy[b])*(dy[a]-dy[b]) );
}

int main()
{
    int d,i;
    scanf("%d%d",&n,&d);
    initialise();
    for(i=0; i<n; i++)//输入坐标
    {
        scanf("%d%d",&dx[i],&dy[i]);
    }

    //操作
    char cmd[2];
    int p,q,len=0;
    while(scanf("%s",cmd)!=EOF)
    {
        switch(cmd[0])
        {
        case 'O':
            scanf("%d",&p);
            p--;
            repair[len++] = p;
            for(i=0; i<len-1; i++)  //遍历所有修过的计算机,看能否联通
                if( repair[i]!=p && Dis(repair[i],p)<=double(d) )
                    union_vertices(repair[i],p);
            break;
        case 'S':
            scanf("%d%d",&p,&q);
            p--,q--;
            if(find_root(p)==find_root(q))    //是否有路
                printf("SUCCESS\n");
            else
                printf("FAIL\n");
        default:
            break;
        }
    }

    return 0;
}
转载:https://www.cnblogs.com/yym2013/p/3877481.html
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值