Wireless Network POJ - 2236 (并查集)

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

 

题意:

  • 有一个计算机网络的所有线路都坏了,网络中有n台计算机,现在你可以做两种操作,
  • 修理(O)和检测两台计算机是否连通(S),只有修理好的计算机才能连通。
  • 连通有个规则,两台计算机的距离不能超过给定的最大距离D(一开始会给你n台计算机的坐标)。 
  • 检测的时候输出两台计算机是否能连通。

思路

  • 每次修理好一台计算机的时候就遍历一下所有修好的计算机,
  • 看距离是否<=D,如果符合说明可以连通,将两台计算机所在集合合并。
  • 每次检查的时候判断一下这两台计算机是否在同一集合中即可。

 超超爱爱~~~并查集模板@QAQ

#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int maxn=10001;
int s[maxn];
int height[maxn]; //用height[i]定义元素i的高度
struct st
{
    int x,y,e;
} t[maxn];
int n,d;

int find_set(int x)
{
    int r = x;
    while ( s[r] != r ) r=s[r]; //找到根结点
    int i = x, j;
    while(i != r)
    {
        j = s[i]; //用临时变量j记录
        s[i]= r ; //把路径上元素的集改为根结点
        i = j;
    }
    return r;
}

void init_set()
{
    for(int i = 1; i <= n; i++)
    {
        s[i] = i;
        height[i]=0;       //初始化树的高度
        t[i].e=0;
    }
}

void union_set(int x, int y)     //优化合并操作
{
    x = find_set(x);
    y = find_set(y);
    if (height[x] == height[y])
    {
        height[x] = height[x] + 1;  //合并,树的高度加1
        s[y] = x;
    }
    else       //把矮树并到高树上,高树的高度保持不变
    {
        if (height[x] < height[y])  s[x] = y;
        else   s[y] = x;
    }
}

int main()
{
    while(~scanf("%d%d",&n,&d))
    {
        init_set();
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d",&t[i].x,&t[i].y);
        }
        char s[6];
        while(~scanf("%s",s))
        {
            if(s[0]=='O') //输入的明明是一个字符,为啥要用字符串呢,那是因为这个字符是每组输入时要第一个输入的,每轮输入结束后还要输入换行符,如果用字符的话,就会把换行符当作下一轮要输入的字符,显然错误。
            {
                int k;
                scanf("%d",&k);//字符O表示维修电脑
                t[k].e=1;//修好的电脑变成1咯,来和坏的分开
                for(int i=1; i<=n; i++)
                {
                    int l=(t[k].x-t[i].x)*(t[k].x-t[i].x)+(t[k].y-t[i].y)*(t[k].y-t[i].y);//这个修好的电脑要和其他所有的电脑算一下距离,距离小于d的才可能合并在一起哟。
                    if(l<=d*d&&t[i].e)//两台距离小于d而且都被修好的电脑才能合并的哟
                    {
                        union_set(k,i);
                    }
                }
            }
            else if(s[0]=='S')//字符S判断是否能够交流了
            {
                int a,b;
                scanf("%d%d",&a,&b);
                if(find_set(a)==find_set(b)&&t[a].e&&t[b].e)//两台电脑都修好了,而且根节点一样了,那就OK了。
                {
                    printf("SUCCESS\n");
                }
                else
                {
                    printf("FAIL\n");
                }
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值